代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/python-decorator 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%global _empty_manifest_terminate_build 0
Name: python-decorator
Version: 5.1.1
Release: 2
Summary: Decorators for Humans
License: BSD
URL: https://github.com/micheles/decorator
Source0: https://files.pythonhosted.org/packages/66/0c/8d907af351aa16b42caae42f9d6aa37b900c67308052d10fdce809f8d952/decorator-5.1.1.tar.gz
BuildArch: noarch
%description
The goal of the decorator module is to make it easy to define signature-preserving
function decorators and decorator factories. It also includes an implementation of multiple dispatch and
other niceties (please check the docs).
%package -n python3-decorator
Summary: Decorators for Humans
Provides: python-decorator
# Base build requires
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-wheel
%description -n python3-decorator
The goal of the decorator module is to make it easy to define signature-preserving
function decorators and decorator factories. It also includes an implementation of multiple dispatch and
other niceties (please check the docs).
%package help
Summary: Decorators for Humans
Provides: python3-decorator-doc
%description help
The goal of the decorator module is to make it easy to define signature-preserving
function decorators and decorator factories. It also includes an implementation of multiple dispatch and
other niceties (please check the docs).
%prep
%autosetup -n decorator-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%check
%{__python3} setup.py test
%files -n python3-decorator -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Oct 20 2022 zhuofeng<zhuofeng2@huawei.com> - 5.1.1-2
- update Release
* Thu May 19 2022 OpenStack_SIG <openstack@openeuler.org> - 5.1.1-1
- Upgrade package python3-decorator to version 5.1.1
* Sat Nov 13 2021 liudabo<liudabo1@huawei.com> - 5.0.9-1
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:update version to 5.0.9
* Fri Oct 23 2020 tianwei<tianwei12@huawei.com> - 4.4.2-2
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:delete python2
* Thu Jul 23 2020 dingyue<dingyue5@huawei.com> - 4.4.2-1
- Type:enhancement
- ID:NA
- SUG:restart
- DESC:update source code
* Tue Dec 31 2019 Yeqing Peng<pengyeqing@huawei.com> - 4.3.0-3
- Type:enhancement
- ID:NA
- SUG:restart
- DESC:update source code
* Tue Sep 10 2019 openEuler Buildteam <buildteam@openeuler.org> - 4.3.0-2
- Package init
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。