代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/python-et_xmlfile 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%global pypi_name et_xmlfile
%global _empty_manifest_terminate_build 0
Name: python-%{pypi_name}
Version: 2.0.0
Release: 1
Summary: An implementation of lxml.xmlfile for the standard library
License: MIT
URL: https://foss.heptapod.net/openpyxl/et_xmlfile
Source0: https://files.pythonhosted.org/packages/source/e/et_xmlfile/et_xmlfile-%{version}.tar.gz
BuildArch: noarch
%description
et_xmlfile is a low memory library for creating large XML files.
It is based upon the xmlfile module from lxml with the aim of allowing code to
be developed that will work with both libraries. It was developed initially for
the openpyxl project but is now a standalone module.
%package -n python3-%{pypi_name}
Summary: An implementation of lxml.xmlfile for the standard library
Provides: python-%{pypi_name}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-%{pypi_name}
et_xmlfile is a low memory library for creating large XML files.
It is based upon the xmlfile module from lxml with the aim of allowing code to
be developed that will work with both libraries. It was developed initially for
the openpyxl project but is now a standalone module.
%prep
%autosetup -n %{pypi_name}-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-%{pypi_name} -f filelist.lst
%doc README.rst
%dir %{python3_sitelib}/*
%changelog
* Wed Oct 30 2024 zhaosaisai <zhaosaisai@kylinos.cn> - 2.0.0-1
- Upgrade to the latest version 2.0.0
- Add new writer methods and namespace elements/resolvers
- Separate new write functionality from elements that have namespaces
- Split everything except the closing tag into a separate fn
- Improve performance with inline qname splitting
- Local refactoring/performance improvements
- Example Change the default write value of the root only ns keyword
- Deprecate python 3.6 and 3.7 because nsetree requires the updated XMLParser
- Disable coveralls unless you know exactly how to get access tokens
* Mon Jul 12 2021 ice-kylin <wminid@yeah.net> - 1.1.0-1
- Initial package
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。