1 Star 0 Fork 5

zhaosai/python-et_xmlfile

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-et_xmlfile.spec 2.94 KB
一键复制 编辑 原始数据 按行查看 历史
zhaosai 提交于 2024-10-30 15:50 . Upgrade to the latest version 2.0.0
%global pypi_name et_xmlfile
%global _empty_manifest_terminate_build 0
Name: python-%{pypi_name}
Version: 2.0.0
Release: 1
Summary: An implementation of lxml.xmlfile for the standard library
License: MIT
URL: https://foss.heptapod.net/openpyxl/et_xmlfile
Source0: https://files.pythonhosted.org/packages/source/e/et_xmlfile/et_xmlfile-%{version}.tar.gz
BuildArch: noarch
%description
et_xmlfile is a low memory library for creating large XML files.
It is based upon the xmlfile module from lxml with the aim of allowing code to
be developed that will work with both libraries. It was developed initially for
the openpyxl project but is now a standalone module.
%package -n python3-%{pypi_name}
Summary: An implementation of lxml.xmlfile for the standard library
Provides: python-%{pypi_name}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-%{pypi_name}
et_xmlfile is a low memory library for creating large XML files.
It is based upon the xmlfile module from lxml with the aim of allowing code to
be developed that will work with both libraries. It was developed initially for
the openpyxl project but is now a standalone module.
%prep
%autosetup -n %{pypi_name}-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-%{pypi_name} -f filelist.lst
%doc README.rst
%dir %{python3_sitelib}/*
%changelog
* Wed Oct 30 2024 zhaosaisai <zhaosaisai@kylinos.cn> - 2.0.0-1
- Upgrade to the latest version 2.0.0
- Add new writer methods and namespace elements/resolvers
- Separate new write functionality from elements that have namespaces
- Split everything except the closing tag into a separate fn
- Improve performance with inline qname splitting
- Local refactoring/performance improvements
- Example Change the default write value of the root only ns keyword
- Deprecate python 3.6 and 3.7 because nsetree requires the updated XMLParser
- Disable coveralls unless you know exactly how to get access tokens
* Mon Jul 12 2021 ice-kylin <wminid@yeah.net> - 1.1.0-1
- Initial package
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/zhaosai-Simon/python-et_xmlfile.git
git@gitee.com:zhaosai-Simon/python-et_xmlfile.git
zhaosai-Simon
python-et_xmlfile
python-et_xmlfile
master

搜索帮助