代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/qtkeychain-qt5 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%bcond_without qt5
%bcond_without qt6
Name: qtkeychain
Version: 0.14.3
Release: 1
Summary: A password store library
License: BSD
Url: https://github.com/frankosterfeld/qtkeychain
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
BuildRequires: make
BuildRequires: gcc-c++
BuildRequires: cmake
BuildRequires: pkgconfig(libsecret-1)
%description
The qtkeychain library allows you to store passwords easily and securely.
%if %{with qt5}
%package qt5
Summary: %{summary}
%description qt5
The qt5keychain library allows you to store passwords easily and securely.
%package qt5-devel
Summary: Development files for %{name}-qt5
BuildRequires: qt5-qtbase-devel
BuildRequires: cmake(Qt5LinguistTools)
Requires: %{name}-qt5%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: qt5-qtbase-devel%{?_isa}
# deps referenced in Qt5KeychainLibraryDepends-relwithdebinfo.cmake: IMPORTED_LINK_INTERFACE_LIBRARIES_RELWITHDEBINFO "Qt5::Core;secret-1;gio-2.0;gobject-2.0;glib-2.0;Qt5::DBus"
# *probably* overlinking and can be pruned, but requires closer inspection
Requires: pkgconfig(libsecret-1)
%description qt5-devel
This package contains development files for qt5keychain.
%endif
%if %{with qt6}
%package qt6
Summary: %{summary}
%description qt6
The qt6keychain library allows you to store passwords easily and securely.
%package qt6-devel
Summary: Development files for %{name}-qt6
BuildRequires: cmake(Qt6Core)
BuildRequires: cmake(Qt6LinguistTools)
Requires: %{name}-qt6%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: qt6-qtbase-devel%{?_isa}
# deps referenced in Qt6KeychainLibraryDepends-relwithdebinfo.cmake: IMPORTED_LINK_INTERFACE_LIBRARIES_RELWITHDEBINFO "Qt6::Core;secret-1;gio-2.0;gobject-2.0;glib-2.0;Qt6::DBus"
# *probably* overlinking and can be pruned, but requires closer inspection
Requires: pkgconfig(libsecret-1)
%description qt6-devel
This package contains development files for qt6keychain.
%endif
%prep
%autosetup -p1
%if %{with qt5}
mkdir %{_target_platform}-qt5
%endif
%if %{with qt6}
mkdir %{_target_platform}-qt6
%endif
%build
%if %{with qt5}
%cmake -B %{_target_platform}-qt5 \
-DBUILD_WITH_QT6:BOOL=OFF \
-DECM_MKSPECS_INSTALL_DIR=%{_qt5_archdatadir}/mkspecs/modules \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
cmake --build %{_target_platform}-qt5 %{?_smp_mflags} --verbose
%endif
%if %{with qt6}
%cmake -B %{_target_platform}-qt6 \
-DBUILD_WITH_QT6:BOOL=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
cmake --build %{_target_platform}-qt6 %{?_smp_mflags} --verbose
%endif
%install
%if %{with qt5}
DESTDIR="%{buildroot}" cmake --install %{_target_platform}-qt5
%endif
%if %{with qt6}
DESTDIR="%{buildroot}" cmake --install %{_target_platform}-qt6
%endif
%find_lang %{name} --with-qt
%if %{with qt5}
grep %{_datadir}/qt5keychain/translations %{name}.lang > %{name}-qt5.lang
%endif
%if %{with qt6}
grep %{_datadir}/qt6keychain/translations %{name}.lang > %{name}-qt6.lang
%endif
%if %{with qt5}
%files qt5 -f %{name}-qt5.lang
%license COPYING
%{_libdir}/libqt5keychain.so.1
%{_libdir}/libqt5keychain.so.0*
%files qt5-devel
%{_includedir}/qt5keychain/
%{_libdir}/cmake/Qt5Keychain/
%{_libdir}/libqt5keychain.so
%{_qt5_archdatadir}/mkspecs/modules/qt_Qt5Keychain.pri
%endif
%if %{with qt6}
%files qt6 -f %{name}-qt6.lang
%license COPYING
%{_libdir}/libqt6keychain.so.1
%{_libdir}/libqt6keychain.so.0*
%files qt6-devel
%{_includedir}/qt6keychain/
%{_libdir}/cmake/Qt6Keychain/
%{_libdir}/libqt6keychain.so
%{_libdir}/qt6/mkspecs/modules/qt_Qt6Keychain.pri
%endif
%changelog
* Thu Nov 14 2024 zhangxianjun <zhangxianjun@kylinos.cn> -0.14.3-1
- update to 0.14.3
- Fix Android build for Qt 6.7 (Volker Krause vkrause@kde.org)
* Tue Jan 09 2024 luojun <luojun.oerv@isrc.iscas.ac.cn> - 0.14.2-1
- Update to 0.14.2
* Thu Sep 07 2023 peijiankang <peijiankang@kylinos.cn> - 0.13.2-1
- 0.13.2
* Thu Apr 27 2023 peijiankang <peijiankang@kylinos.cn> - 0.11.1-1
- Init Package for openEuler
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。