代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/perl-File-Temp 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%define cpan_name File-Temp
%define cpan_version 0.2311
Name: perl-File-Temp
Epoch: 1
Version: 0.2311
Release: 2
Summary: Return name and handle of a temporary file safely
License: GPL+ or Artistic
URL: https://metacpan.org/release/File-Temp
Source0: https://cpan.metacpan.org/authors/id/E/ET/ETHER/%{cpan_name}-%{cpan_version}.tar.gz
BuildArch: noarch
BuildRequires: coreutils make perl(POSIX) perl(strict) perl(warnings) perl(Carp) perl(constant)
BuildRequires: perl-generators perl-interpreter perl(Scalar::Util) perl(FileHandle) perl(Test::More)
BuildRequires: perl(Cwd) perl(Errno) perl(IO::Handle) perl(IO::Seekable) perl(overload) perl(Config)
BuildRequires: perl(:VERSION) >= 5.6
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
BuildRequires: perl(Exporter) >= 5.57
BuildRequires: perl(Fcntl) >= 1.03
BuildRequires: perl(File::Path) >= 2.06
BuildRequires: perl(File::Spec) >= 0.8
BuildRequires: perl(parent) >= 0.221
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
Requires: perl(POSIX)
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(Symbol|VMS::Stdio\\)
%description
File::Temp can be used to create and open temporary files in a safe way.
There is both a function interface and an object-oriented interface. The
File::Temp constructor or the tempfile() function can be used to return the
name and the open file handle of a temporary file. The tempdir() function
can be used to create a temporary directory.
The security aspect of temporary file creation is emphasized such that a
filehandle and filename are returned together.
This helps guarantee that a race condition can not occur where the temporary
file is created by another process between checking for the existence of the
file and its opening. Additional security levels are provided to check,
for example, that the sticky bit is set on world writable directories.
See "safe_level" for more information.
For compatibility with popular C library functions, Perl implementations of
the mkstemp() family of functions are provided. These are, mkstemp(),
mkstemps(), mkdtemp() and mktemp().
Additionally, implementations of the standard POSIX tmpnam() and tmpfile()
functions are provided if required.
Implementations of mktemp(), tmpnam(), and tempnam() are provided, but should
be used with caution since they return only a filename that was valid when
function was called, so cannot guarantee that the file will not exist by the
time the caller opens the filename.
Filehandles returned by these functions support the seekable methods.
%package help
Summary: man files for perl-File-Temp
BuildArch: noarch
Requires: man
%description help
This package includes man files for File::Temp
%prep
%autosetup -n %{cpan_name}-%{cpan_version} -p1
chmod -x misc/benchmark.pl
perl -MConfig -p -i -e 's|\A#!/usr/local/bin/perl\b|$Config{startperl}|' \
misc/benchmark.pl
%build
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
%make_build
%install
make pure_install DESTDIR=%{buildroot}
%{_fixperms} %{buildroot}/*
%check
make test
%files
%doc Changes misc README
%license LICENSE
%{perl_vendorlib}/*
%files help
%{_mandir}/man3/*
%changelog
* Fri Jul 30 2021 chenyanpanHW <chenyanpan@huawei.com> - 0.2311-2
- DESC: delete -Sgit from %autosetup, and delete BuildRequires git
* Wed Feb 03 2021 yuanxin <yuanxin24@huawei.com> - 1:0.2311-1
- Upgrade to version 0.2311
* Thu Jul 23 2020 xinghe <xinghe1@huawei.com> - 1:0.230.900-1
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:update version to 0.2309
* Fri Sep 27 2019 shenyangyang<shenyangyang4@huawei.com> - 1:0.230.800-4
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:move the license file
* Sun Sep 15 2019 openEuler Buildteam <buildteam@openeuler.org> - 1:0.230.800-3
- Package init
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。