代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/libfm 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%global bootstrap 0
%undefine prever
%global build_doc 1
%undefine _changelog_trimtime
Name: libfm
Version: 1.3.2
Release: 1
Summary: GIO-based library for file manager-like programs
License: GPLv2+
URL: http://pcmanfm.sourceforge.net/
Source0: http://downloads.sourceforge.net/pcmanfm/%{name}-%{version}.tar.xz
Source1: https://raw.githubusercontent.com/lxde/libfm/master/autogen.sh
Source10: create-libfm-git-bare-tarball.sh
Patch1: libfm-1.3.2-0001-fm_config_load_from_key_file-don-t-replace-string-va.patch
Patch1000: libfm-1.3.0.2-moduledir-gtkspecific-v03.patch
BuildRequires: libexif-devel
BuildRequires: gtk3-devel
BuildRequires: gtk2-devel
BuildRequires: glib2-devel
BuildRequires: pkgconfig(pango)
BuildRequires: pkgconfig(cairo)
%if ! 0%{?bootstrap}
BuildRequires: menu-cache-devel >= 0.3.2
%endif
BuildRequires: gcc
BuildRequires: gettext
BuildRequires: intltool
BuildRequires: desktop-file-utils
BuildRequires: gtk-doc
BuildRequires: libxslt
BuildRequires: dbus-glib-devel
BuildRequires: vala
BuildRequires: automake
BuildRequires: libtool
BuildRequires: git
%if 0%{?build_doc} < 1
Obsoletes: %{name}-devel-docs < 0.1.15
%endif
%description
LibFM is a GIO-based library used to develop file manager-like programs. It is
developed as the core of next generation PCManFM and takes care of all file-
related operations such as copy & paste, drag & drop, file associations or
thumbnails support. By utilizing glib/gio and gvfs, libfm can access remote
file systems supported by gvfs.
This package contains the generic non-gui functions of libfm.
%package gtk
Summary: File manager-related GTK+ widgets of %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: gvfs
%description gtk
libfm is a GIO-based library used to develop file manager-like programs. It is
developed as the core of next generation PCManFM and takes care of all file-
related operations such as copy & paste, drag & drop, file associations or
thumbnail support. By utilizing glib/gio and gvfs, libfm can access remote
file systems supported by gvfs.
This package provides useful file manager-related GTK+ 3 widgets.
%package gtk2
Summary: File manager-related GTK+ widgets of %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: gvfs
%description gtk2
libfm is a GIO-based library used to develop file manager-like programs. It is
developed as the core of next generation PCManFM and takes care of all file-
related operations such as copy & paste, drag & drop, file associations or
thumbnail support. By utilizing glib/gio and gvfs, libfm can access remote
file systems supported by gvfs.
This package provides useful file manager-related GTK+ 2 widgets.
%package gtk-utils
Summary: GTK+ related utility package for %{name}
Requires: %{name}-gtk%{?isa} = %{version}-%{release}
Obsoletes: lxshortcut < 0.1.3
Provides: lxshortcut = %{version}-%{release}
Provides: lxshortcut%{?_isa} = %{version}-%{release}
%description gtk-utils
This package contains some GTK+ related utility files for
%{name}.
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%package gtk-devel-common
Summary: Common Development files for %{name}-gtk
Requires: %{name}-devel = %{version}-%{release}
BuildArch: noarch
%description gtk-devel-common
The %{name}-gtk-devel package contains common header files for
developing applications that use %{name}-gtk.
%package gtk-devel
Summary: Development files for %{name}-gtk
Requires: %{name}-gtk%{?_isa} = %{version}-%{release}
Requires: %{name}-gtk-devel-common = %{version}-%{release}
%description gtk-devel
The %{name}-gtk-devel package contains libraries files for
developing applications that use %{name}-gtk.
%package gtk2-devel
Summary: Development files for %{name}-gtk2
Requires: %{name}-gtk2%{?_isa} = %{version}-%{release}
Requires: %{name}-gtk-devel-common = %{version}-%{release}
%description gtk2-devel
The %{name}-gtk2-devel package contains libraries files for
developing applications that use %{name}-gtk2.
%package devel-docs
Summary: Development documation for %{name}
%description devel-docs
This package containg development documentation files for %{name}.
%prep
%setup -q -n %{name}-%{version}%{?prever}
cp -a %{SOURCE1} .
%patch1000 -p1
sh autogen.sh
sed -i.libdir_syssearch \
-e '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib /lib64 |' \
configure
%build
for ver in \
2 \
3 \
%{nil}
do
rm -rf _BUILDDIR_gtk${ver}
mkdir _BUILDDIR_gtk${ver}
pushd _BUILDDIR_gtk${ver}
ln -sf ../configure
%configure \
--srcdir=$(pwd)/.. \
%if 0%{?bootstrap}
--with-extra-only \
%endif
--enable-gtk-doc \
--enable-udisks \
--with-gtk=${ver} \
%if 0
--enable-demo \
%endif
--disable-silent-rules \
--disable-static
# To show translation status
make -C po -j1 GMSGFMT="msgfmt --statistics"
make %{?_smp_mflags} -k
make install DESTDIR=$(pwd)/../INSTDIR-gtk${ver}
popd
done
%install
TOPDIR=$(pwd)
# GTK3
cp -a INSTDIR-gtk3/* $RPM_BUILD_ROOT
rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libfm-gtk.pc
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%if ! 0%{?bootstrap}
desktop-file-validate %{buildroot}/%{_datadir}/applications/*.desktop
(
cd $TOPDIR
%find_lang %{name}
)
%endif
echo '%%defattr(-,root,root,-)' > $TOPDIR/base-header.files
echo '%%defattr(-,root,root,-)' > $TOPDIR/gtk-header.files
for f in $RPM_BUILD_ROOT%_includedir/%name-1.0/*.h
do
bf=$(basename $f)
for dir in actions base job extra .
do
if [ -f src/$dir/$bf ]
then
echo %_includedir/%name-1.0/$bf >> $TOPDIR/base-header.files
fi
done
for dir in gtk
do
if [ -f src/$dir/$bf ]
then
echo %_includedir/%name-1.0/$bf >> $TOPDIR/gtk-header.files
fi
done
done
%if ! 0%{?bootstrap}
pushd INSTDIR-gtk2
find . -name '*.la' -exec rm -f {} ';'
rm -f .{_libdir}/pkgconfig/libfm-gtk3.pc
diff -urNp .%{_includedir}/%{name}-1.0 $RPM_BUILD_ROOT%{_includedir}/%name-1.0
diff -urNp .%{_datadir}/%{name} $RPM_BUILD_ROOT/%{_datadir}/%{name}
cp -a ./%{_libdir}/libfm-gtk* $RPM_BUILD_ROOT%{_libdir}
cp -a ./%{_libdir}/pkgconfig/libfm-gtk.pc \
$RPM_BUILD_ROOT%{_libdir}/pkgconfig/
cp -a ./%{_libdir}/libfm/modules/gtk/ \
$RPM_BUILD_ROOT%{_libdir}/libfm/modules/
popd
%endif
/usr/lib/rpm/check-rpaths
%check
find INSTDIR-gtk* -name \*.ui >> po/POTFILES.skip
for ver in \
2 \
3 \
%{nil}
do
pushd _BUILDDIR_gtk${ver}
make check
popd
done
%pre devel
if [ -d %{_includedir}/libfm ] ; then
rm -rf %{_includedir}/libfm
fi
%if 0%{?bootstrap}
%files
%else
%files -f %{name}.lang
%endif
%doc AUTHORS
%license COPYING
%doc NEWS
%doc README
%if ! 0%{?bootstrap}
%dir %{_sysconfdir}/xdg/libfm/
%config(noreplace) %{_sysconfdir}/xdg/libfm/libfm.conf
%{_datadir}/%{name}/
%{_libdir}/%{name}.so.4*
%dir %{_libdir}/libfm
%dir %{_libdir}/libfm/modules
%{_libdir}/libfm/modules/vfs-*.so
%{_datadir}/mime/packages/libfm.xml
%endif
%{_libdir}/%{name}-extra.so.4*
%if ! 0%{?bootstrap}
%files gtk
%{_libdir}/%{name}-gtk3.so.4*
%{_libdir}/libfm/modules/gtk3/
%files gtk-utils
%{_mandir}/man1/libfm-pref-apps.1.*
%{_mandir}/man1/lxshortcut.1.*
%{_bindir}/libfm-pref-apps
%{_bindir}/lxshortcut
%{_datadir}/applications/libfm-pref-apps.desktop
%{_datadir}/applications/lxshortcut.desktop
%endif
%files devel -f base-header.files
%doc TODO
%{_includedir}/libfm
%dir %{_includedir}/libfm-1.0/
%if ! 0%{?bootstrap}
%{_libdir}/%{name}.so
%{_libdir}/pkgconfig/libfm.pc
%endif
%{_libdir}/%{name}-extra.so
%{_libdir}/pkgconfig/libfm-extra.pc
%if ! 0%{?bootstrap}
%files gtk-devel-common -f gtk-header.files
%{_includedir}/libfm-1.0/fm-gtk.h
%files gtk-devel
%{_libdir}/%{name}-gtk3.so
%{_libdir}/pkgconfig/libfm-gtk3.pc
%files gtk2
%{_libdir}/%{name}-gtk.so.4*
%{_libdir}/libfm/modules/gtk/
%files gtk2-devel
%{_libdir}/%{name}-gtk.so
%{_libdir}/pkgconfig/libfm-gtk.pc
%if 0%{?build_doc}
%files devel-docs
%dir %{_datadir}/gtk-doc
%dir %{_datadir}/gtk-doc/html
%{_datadir}/gtk-doc/html/%{name}
%endif
%endif
%changelog
* Mon Jan 02 2023 lin zhang <lin.zhang@turbolinux.com.cn> - 1.3.2-1
- update to 1.3.2
* Tue Aug 3 2021 chainsx <chainsx@isrc.iscas.ac.cn> - 1.3.1-1
- Initial openEuler package
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。