代码拉取完成,页面将自动刷新
Summary: PROVIDERS Package
Name: providers
Version: 1.0
Release: 1
License: MIT
Group: Applications/System
URL: https://example.com/providers
Source0: %{name}-%{version}.tar.gz
BuildArch: noarch
Requires: ruby rubygems ruby-devel gcc make tar gzip openssl-devel gcc-c++ zlib iproute wget docker git
%description
This is the CCB package.
%prep
%setup -q
%install
# Extract the tar package
mkdir -p %{buildroot}/usr/libexec/
tar -zxvf %{SOURCE0} -C %{buildroot}/usr/libexec/
%post
# disable swap
swapoff -a
sed -i '/swap/d' /etc/fstab
id -u lkp || useradd -u 1090 lkp
sh /usr/libexec/%{name}-%{version}/cbs/sparrow/1-storage/tiny
# Install gem packages
#gem sources -r https://rubygems.org/ -a https://mirrors.huaweicloud.com/repository/rubygems/
gem sources -r https://rubygems.org/ -a https://gems.ruby-china.com/
gem install -f git activesupport rest-client cucumber json faye-websocket elasticsearch bunny nokogiri
# Create the symbolic link
ln -sf /usr/libexec/%{name}-%{version}/cbs/providers/multi-docker /usr/sbin/multi-docker
sh -x /usr/libexec/%{name}-%{version}/arch_configuration.sh openEuler-22.03-LTS-Loongarch
if [ ! -f "/etc/compass-ci/passwd.yaml" ]; then
echo "Please complete the content of the configuration file /etc/compass-ci/passwd.yaml"
cat > "/etc/compass-ci/passwd.yaml" <<-EOF
ACCOUNT:
PASSWORD:
OAUTH_TOKEN_URL: https://omapi.osinfra.cn/oneid/oidc/token
OAUTH_REDIRECT_URL: https://eulermaker.compass-ci.openeuler.openatom.cn/oauth/
PUBLIC_KEY_URL: https://omapi.osinfra.cn/oneid/public/key?community=openeuler
DOMAIN_NAME: eulermaker.compass-ci.openeuler.openatom.cn
EOF
fi
if [ ! -f "/etc/compass-ci/service/service-env.yaml" ]; then
echo "Please complete the content of the configuration file /etc/compass-ci/service/service-env.yaml"
cat > "/etc/compass-ci/service/service-env.yaml" <<-EOF
DOMAIN_NAME: eulermaker.compass-ci.openeuler.openatom.cn
EOF
fi
# add env for CCI_SRC
if [ -z "$CCI_SRC" ]; then
echo export CCI_SRC=/usr/libexec/%{name}-%{version}/cbs >> $HOME/.${os_shell}rc
fi
if [ -z "$LKP_SRC" ]; then
echo export LKP_SRC=/usr/libexec/%{name}-%{version}/lkp-tests >> $HOME/.${os_shell}rc
fi
chmod 773 /etc/.ccache
#os_shell=$(basename $SHELL)
#echo export CCI_SRC=/c/cbs >> $HOME/.${os_shell}rc
#echo export LKP_SRC=/c/lkp-tests >> $HOME/.${os_shell}rc
%postun
rm -rf /usr/libexec/%{name}-%{version}
rm -rf /usr/sbin/multi-docker
%files
/usr/libexec/%{name}-%{version}/*
%changelog
* Mon Nov 14 2023 ych 1.0-1
- Initial package release
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。