代码拉取完成,页面将自动刷新
同步操作将从 XingYuShuai/bisheng 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
Name: bisheng-compiler
Version: 2.3.0
Release: 1
Summary: BiSheng Compiler released by huawei
Group: Development/System
License: MIT
#URL:
AutoReq: no
Requires: glibc >= 2.17 python3
%description
The Bisheng compiler is developed based on the open source LLVM, and has been deeply optimized and improved. In addition to the general functions and optimizations of LLVM, the key technical points of the mid-range and back-end are deeply optimized, and the Auto-tuner feature is integrated to support automatic compiler tuning. Front-end supports c/c++, Fortran. The operating system currently only supports linux, and the verified operating systems are CentOS7.6, openEuler20.09, openEuler20.03 LTS SP1, UOSV20 and Kirin V10 operating systems.
%build
%install
mkdir -p %{buildroot}/usr/local/
cd %{_builddir}
if [ %{_arch} == aarch64 ];then
cat %{_sourcedir}/%{name}-%{version}-aarch64-linux.aa %{_sourcedir}/%{name}-%{version}-aarch64-linux.ab %{_sourcedir}/%{name}-%{version}-aarch64-linux.ac %{_sourcedir}/%{name}-%{version}-aarch64-linux.ad %{_sourcedir}/%{name}-%{version}-aarch64-linux.ae %{_sourcedir}/%{name}-%{version}-aarch64-linux.af %{_sourcedir}/%{name}-%{version}-aarch64-linux.ag %{_sourcedir}/%{name}-%{version}-aarch64-linux.ah %{_sourcedir}/%{name}-%{version}-aarch64-linux.ai > %{_sourcedir}/%{name}-%{version}-aarch64-linux.tar.gz
tar -xvf %{_sourcedir}/%{name}-%{version}-aarch64-linux.tar.gz
chmod 755 -R %{name}-%{version}-aarch64-linux/*
cp -rf %{_builddir}/%{name}-%{version}-aarch64-linux/* %{buildroot}/usr/local/
elif [ %{_arch} == x86_64 ];then
cat %{_sourcedir}/%{name}-%{version}-x86-linux.aa %{_sourcedir}/%{name}-%{version}-x86-linux.ab %{_sourcedir}/%{name}-%{version}-x86-linux.ac %{_sourcedir}/%{name}-%{version}-x86-linux.ad %{_sourcedir}/%{name}-%{version}-x86-linux.ae %{_sourcedir}/%{name}-%{version}-x86-linux.af %{_sourcedir}/%{name}-%{version}-x86-linux.ag %{_sourcedir}/%{name}-%{version}-x86-linux.ah %{_sourcedir}/%{name}-%{version}-x86-linux.ai %{_sourcedir}/%{name}-%{version}-x86-linux.aj %{_sourcedir}/%{name}-%{version}-x86-linux.ak %{_sourcedir}/%{name}-%{version}-x86-linux.al %{_sourcedir}/%{name}-%{version}-x86-linux.am > %{_sourcedir}/%{name}-%{version}-x86-linux.tar.gz
tar -xvf %{_sourcedir}/%{name}-%{version}-x86-linux.tar.gz
chmod 755 -R %{name}-%{version}-x86-linux/*
cp -rf %{_builddir}/%{name}-%{version}-x86-linux/* %{buildroot}/usr/local/
fi
%define __debug_install_post \
%{_rpmconfigdir}/find-debuginfo.sh %{?_find_debuginfo_opts} "%{_builddir}/%{?buildsubdir}"\
%{nil}
%post
if [ $1 == 1 ];then
echo "-----------------------"
echo "bisheng is getting installed"
echo "Warning: please execute the 'hash -r' command in the current shell window, otherwise the Bisheng compiler may not be available in the current shell window.Or you can open a new shell window and use the Bisheng compiler."
echo "-----------------------"
elif [ $1 == 2 ];then
echo "-----------------------"
echo "bisheng is getting upgraded"
echo "-----------------------"
fi
%postun
if [ $1 == 0 ];then
echo "------------------------------"
echo "bisheng is getting uninstalled"
echo "Warning: please execute the 'hash -r' command in the current shell window, otherwise the open source LLVM compiler may not be available in the current shell window.Or you can open a new shell window and use the open source LLVM compiler."
echo "------------------------------"
fi
%files
/usr/local/bin/*
/usr/local/lib/*
/usr/local/include/*
/usr/local/libexec/*
/usr/local/share/*
%changelog
* Wed Jul 20 2022 xingyushuai <xingyushuai@huawei.com> - 2.3.0 - 1
- Release BiSheng Compiler 2.3.0
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。