1 Star 0 Fork 4

woody2918/perl-Test-Trap

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
perl-Test-Trap.spec 3.24 KB
一键复制 编辑 原始数据 按行查看 历史
woody2918 提交于 2024-02-04 11:09 . update version to 0.3.5
%global _empty_manifest_terminate_build 0
Name: perl-Test-Trap
Version: 0.3.5
Release: 1
Summary: Trap exit codes, exceptions, output, etc
License: GPL+ or Artistic
Group: Development/Libraries
URL: http://search.cpan.org/dist/Test-Trap/
Source0: http://www.cpan.org/authors/id/E/EB/EBHANSSEN/Test-Trap-v%{version}.tar.gz
BuildArch: noarch
BuildRequires: perl >= 1:v5.6.2
BuildRequires: perl-generators
BuildRequires: perl(base)
BuildRequires: perl(Carp)
BuildRequires: perl(Config)
BuildRequires: perl(constant)
BuildRequires: perl(Data::Dump)
BuildRequires: perl(Exporter)
BuildRequires: perl(File::Temp)
BuildRequires: perl(IO::Handle)
BuildRequires: perl(lib)
BuildRequires: perl(Module::Build)
BuildRequires: perl(strict)
BuildRequires: perl(Test::Builder)
BuildRequires: perl(Test::More)
BuildRequires: perl(Test::Tester) >= 0.107
BuildRequires: perl(version)
BuildRequires: perl(warnings)
Requires: perl(base)
Requires: perl(Carp)
Requires: perl(Config)
Requires: perl(constant)
Requires: perl(Data::Dump)
Requires: perl(Exporter)
Requires: perl(File::Temp)
Requires: perl(IO::Handle)
Requires: perl(lib)
Requires: perl(strict)
Requires: perl(Test::Builder)
Requires: perl(Test::More)
Requires: perl(Test::Tester) >= 0.107
Requires: perl(version)
Requires: perl(warnings)
%description
Primarily (but not exclusively) for use in test scripts: A block eval on
steroids, configurable and extensible, but by default trapping (Perl)
STDOUT, STDERR, warnings, exceptions, would-be exit codes, and return
values from boxed blocks of test code.
%package help
Summary : Trap exit codes, exceptions, output, etc
Provides: perl-Test-Trap-doc
%description help
Primarily (but not exclusively) for use in test scripts: A block eval on
steroids, configurable and extensible, but by default trapping (Perl)
STDOUT, STDERR, warnings, exceptions, would-be exit codes, and return
values from boxed blocks of test code.
%prep
%setup -q -n Test-Trap-v%{version}
%build
export PERL_MM_OPT=""
%{__perl} Build.PL --installdirs=vendor
./Build
%install
export PERL_MM_OPT=""
rm -rf $RPM_BUILD_ROOT
./Build install --destdir=$RPM_BUILD_ROOT --create_packlist=0
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
%{_fixperms} $RPM_BUILD_ROOT/*
pushd %{buildroot}
touch filelist.lst
if [ -d usr/bin ];then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ];then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ];then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib ];then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
popd
mv %{buildroot}/filelist.lst .
%check || :
./Build test
%clean
rm -rf $RPM_BUILD_ROOT
%files -f filelist.lst
%defattr(-,root,root,-)
%doc Changes META.json README xt
%{perl_vendorlib}/*
%files help
%{_mandir}/*
%changelog
* Sun Feb 04 2024 woody2918 <wudi1@uniontech.com> 0.3.5-1
- update version to 0.3.5
- changes to tests
- Stop using bareword filehandles; if it isn't deprecated already, it will be.
* Sun May 23 2021 Perl_Bot <Perl_Bot@openeuler.org> 0.3.4-1
- Specfile autogenerated by Perl_Bot
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/woody2918/perl-Test-Trap.git
git@gitee.com:woody2918/perl-Test-Trap.git
woody2918
perl-Test-Trap
perl-Test-Trap
master

搜索帮助