1 Star 0 Fork 13

sxtywg/python-elementpath

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-elementpath.spec 3.68 KB
一键复制 编辑 原始数据 按行查看 历史
sxtywg 提交于 2024-10-30 17:06 . update version to 4.6.0
%global _empty_manifest_terminate_build 0
Name: python-elementpath
Version: 4.6.0
Release: 1
Summary: XPath 1.0/2.0 parsers and selectors for ElementTree and lxml
License: MIT
URL: https://github.com/sissaschool/elementpath
Source0: https://files.pythonhosted.org/packages/00/85/1c6b109252ae6d295c762f3c9f49409203cbb09ec5d34fb088f90d8dbed7/elementpath-4.6.0.tar.gz
BuildArch: noarch
%description
XPath 1.0/2.0 parsers and selectors for ElementTree and lxml
%package -n python3-elementpath
Summary: XPath 1.0/2.0 parsers and selectors for ElementTree and lxml
Provides: python-elementpath = %{version}-%{release}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-wheel
BuildRequires: python3-tox
%description -n python3-elementpath
XPath 1.0/2.0 parsers and selectors for ElementTree and lxml
%package help
Summary: XPath 1.0/2.0 parsers and selectors for ElementTree and lxml
Provides: python3-elementpath-doc
%description help
XPath 1.0/2.0 parsers and selectors for ElementTree and lxml
%prep
%autosetup -n elementpath-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-elementpath -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Oct 30 2024 wanggang <wanggang1@kylinos.cn> - 4.6.0-1
- update version to 4.6.0
* Tue Oct 8 2024 wuzhaomin <wuzhaomin@kylinos.cn> - 4.5.0-1
- update version to 4.5.0
- Fix and clean node trees iteration methods
- Fix code blocks in README.rst
- Fix missing raw string for '[^\r\n]'s
- Fix XPath default namespace usage in ElementNode.match_name()
- Fix context variables init: do not listify single values
* Fri Mar 29 2024 wangqiang <wangqiang1@kylinos.cn> - 4.4.0-1
- Update package to version 4.4.0
* Thu Mar 7 2024 Dongxing Wang <dongxing.wang_a@thundersoft.com> - 4.3.0-1
- Update package to version 4.3.0
Change the purpose of the evaluation with a dynamic schema context
The static evaluation is now performed also when a schema is provided to the parser
Add uri and fragment options to dynamic context
Drop support for Python 3.7
Make context root node not mandatory
* Wed Jan 10 2024 Dongxing Wang <dongxing.wang_a@thundersoft.com> - 4.1.5-1
- Update package to version 4.1.5
* Tue Nov 22 2022 liqiuyu <liqiuyu@kylinos.cn> - 3.0.2-1
- Update package to version 3.0.2
* Mon Jul 18 2022 OpenStack_SIG <openstack@openeuler.org> - 2.4.0-1
- Upgrade package python3-elementpath to version 2.4.0
* Mon Aug 2 2021 OpenStack_SIG <openstack@openeuler.org> - 2.2.0-3
- Drop useless requires
* Fri Jul 30 2021 chenyanpanHW <chenyanpan@huawei.com> - 2.2.0-2
- DESC: delete -S git from %autosetup
* Mon Jul 19 2021 OpenStack_SIG <openstack@openeuler.org> - 2.2.0-1
- Package Spec generate
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/sxtywg/python-elementpath.git
git@gitee.com:sxtywg/python-elementpath.git
sxtywg
python-elementpath
python-elementpath
master

搜索帮助