1 Star 0 Fork 12

starlet_dx/python-pyinstaller

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-pyinstaller.spec 2.93 KB
一键复制 编辑 原始数据 按行查看 历史
jiangxinyu 提交于 2024-03-05 15:47 . Update package to version 6.4.0
%global _empty_manifest_terminate_build 0
Name: python-pyinstaller
Version: 6.4.0
Release: 1
Summary: PyInstaller bundles a Python application and all its dependencies into a single package.
License: GPL-2.0-only
URL: http://www.pyinstaller.org
Source0: https://files.pythonhosted.org/packages/83/5c/752340e73c195e21112eaec094d2d176705e4c18dc42a8357b68bb0dd693/pyinstaller-6.4.0.tar.gz
BuildRequires: python3-devel python3-setuptools zlib-devel
BuildRequires: python3-wheel
%description
PyInstaller bundles a Python application and all its dependencies into a single
package. The user can run the packaged app without installing a Python
interpreter or any modules.
%package -n python3-pyinstaller
Summary: PyInstaller bundles a Python application and all its dependencies into a single package.
Provides: python-PyInstaller
BuildRequires: python3-devel python3-setuptools
%description -n python3-pyinstaller
PyInstaller bundles a Python application and all its dependencies into a single
package. The user can run the packaged app without installing a Python
interpreter or any modules.
%package help
Summary: Development documents and examples for PyInstaller
Provides: python3-PyInstaller-doc
%description help
PyInstaller bundles a Python application and all its dependencies into a single
package. The user can run the packaged app without installing a Python
interpreter or any modules.
%prep
%autosetup -n pyinstaller-%{version} -p1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyinstaller -f filelist.lst
%dir %{python3_sitelib}/*
%exclude %{python3_sitelib}/PyInstaller/bootloader/{D*,W*,*32*,Linux-64bit}
%files help -f doclist.lst
%{_pkgdocdir}
%changelog
* Tue Mar 05 2024 jiangxinyu <jiangxinyu@kylinos.cn> - 6.4.0-1
- Update package to version 6.4.0
Improve collection of QtWebEngineProcess helper and ensure Qt is relocatable
* Mon Jul 10 2023 chenzixuan <chenzixuan@kylinos.cn> - 5.13.0-1
- Update to 5.13.0
* Tue May 16 2023 yaoxin <yao_xin001@hoperun.com> - 5.10.1-1
- Update to 5.10.1
* Mon Jun 22 2020 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/starlet-dx/python-pyinstaller.git
git@gitee.com:starlet-dx/python-pyinstaller.git
starlet-dx
python-pyinstaller
python-pyinstaller
master

搜索帮助