21 Star 0 Fork 1

src-openEuler/swoole

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
swoole.spec 2.24 KB
一键复制 编辑 原始数据 按行查看 历史
扣肉酱 提交于 2024-08-28 12:51 . 5.1.4
%global ini_name 40-swoole.ini
Name: swoole
Version: 5.1.4
Release: 1
Summary: Event-driven asynchronous and concurrent networking engine with high performance for PHP
License: Apache 2.0
URL: https://www.swoole.com/
Source0: https://github.com/swoole/swoole-src/archive/refs/tags/v%{version}.tar.gz
BuildRequires: php(language) >= 8.0
BuildRequires: php-cli >= 8.0
BuildRequires: php-devel
BuildRequires: openssl-devel >= 1.0.2
BuildRequires: curl-devel
BuildRequires: c-ares-devel
BuildRequires: libnghttp2-devel
BuildRequires: pkgconfig(libbrotlienc)
BuildRequires: pkgconfig(libbrotlidec)
BuildRequires: libpq-devel
Requires: php(api) = %{php_core_api}
Requires: php-curl
%description
Event-driven asynchronous and concurrent networking engine with high performance for PHP.
- event-driven
- coroutine
- asynchronous non-blocking
- multi-thread reactor
- multi-process worker
- multi-protocol
- millisecond timer
- built-in tcp/http/websocket/http2 server
- coroutine tcp/http/websocket client
- coroutine mysql client
- coroutine redis client
- coroutine read/write file system
- coroutine dns lookup
- support IPv4/IPv6/UnixSocket/TCP/UDP
- support SSL/TLS encrypted transmission
%package devel
Summary: Development files for %{name}
Requires: %{name} = %{version}
Requires: php-devel >= 8.0
%description devel
Development files for %{name}.
%prep
%autosetup -p1 -n %{name}-src-%{version}
# Drop in the bit of configuration
cat << 'EOF' | tee %{ini_name}
; Enable swoole extension module
extension = swoole.so
EOF
%build
%{_bindir}/phpize
%configure \
--enable-openssl \
--with-openssl-dir=%{_prefix} \
--enable-brotli \
--enable-cares \
--enable-swoole-curl \
--with-nghttp2-dir=%{_prefix} \
--enable-swoole-pgsql
%make_build
%install
%make_install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%files
%license LICENSE
%{php_inidir}/%{ini_name}
%{_libdir}/php/modules/swoole.so
%files devel
%{_includedir}/php/ext/swoole
%changelog
* Wed Aug 28 2024 Funda Wang <fundawang@yeah.net> - 5.1.4-1
- update to 5.1.4
* Wed Jul 31 2024 Funda Wang <fundawang@yeah.net> - 5.1.3-1
- update to version 5.1.3
* Mon Aug 21 2023 Funda Wang <fundawang@yeah.net> - 5.0.3-1
- Import package
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/swoole.git
git@gitee.com:src-openeuler/swoole.git
src-openeuler
swoole
swoole
master

搜索帮助

D67c1975 1850385 1daf7b77 1850385