10 Star 0 Fork 4

src-openEuler/spirv-llvm-translator

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
spirv-llvm-translator.spec 2.48 KB
一键复制 编辑 原始数据 按行查看 历史
Funda Wang 提交于 2024-11-12 13:00 +08:00 . adopt to new cmake macro
%global spirv_headers_version 1.3.261.1
%bcond_without bisheng_autotuner
Name: spirv-llvm-translator
Version: 17.0.0
Release: 4
Summary: LLVM to SPIRV Translator
License: NCSA
URL: https://github.com/KhronosGroup/SPIRV-LLVM-Translator
Source0: https://github.com/KhronosGroup/SPIRV-LLVM-Translator/archive/refs/tags/SPIRV-LLVM-Translator-%{version}.tar.gz
Source1: https://github.com/KhronosGroup/SPIRV-Headers/archive/refs/tags/sdk-%{spirv_headers_version}.tar.gz
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: cmake
BuildRequires: ninja-build
BuildRequires: llvm-devel
BuildRequires: llvm-static
BuildRequires: llvm-test
%description
Khronos LLVM to SPIRV Translator. This is a library
to be used by Mesa for OpenCL support. It translate
LLVM IR to Khronos SPIR-V. It also includes a
standalone tool used for building libclc.
%package devel
Summary: Development files for LLVM to SPIRV Translator
Requires: %{name} = %{version}-%{release}
%description devel
This package contains libraries and header files for
developing against %{name}
%package tools
Summary: Standalone llvm to spirv translator tool
Requires: %{name} = %{version}-%{release}
%description tools
This package contains the standalone llvm to spirv tool.
%prep
%setup -T -q -b 1 -n SPIRV-Headers-sdk-%{spirv_headers_version}
cd ..
mv SPIRV-Headers-sdk-%{spirv_headers_version} SPIRV-Headers
%autosetup -n SPIRV-LLVM-Translator-%{version}
%build
%cmake -GNinja \
-DLLVM_BUILD_TOOLS=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR=%{_builddir}/SPIRV-Headers \
%if %{with bisheng_autotuner}
-DLLVM_ENABLE_AUTOTUNER=ON \
%endif
-DCMAKE_INSTALL_RPATH:BOOL=";"
%cmake_build
%install
%cmake_install
%files
%doc README.md
%{_libdir}/libLLVMSPIRVLib.so.*
%files tools
%{_bindir}/llvm-spirv
%files devel
%{_includedir}/LLVMSPIRVLib
%{_libdir}/libLLVMSPIRVLib.so
%{_libdir}/pkgconfig/LLVMSPIRVLib.pc
%changelog
* Tue Nov 12 2024 Funda Wang <fundawang@yeah.net> - 17.0.0-4
- adopt to new cmake macro
* Tue Nov 12 2024 liyunfei <liyunfei33@huawei.com> - 17.0.0-3
- Fix for cmake macros.
* Tue Aug 20 2024 liyunfei <liyunfei33@huawei.com> - 17.0.0-2
- Add BiSheng Autotuner support.
* Tue Dec 5 2023 zhoujing <zhoujing106@huawei.com> - 17.0.0-1
- Update to 17.0.0
* Thu Jun 8 2023 cf-zhao <zhaochuanfeng@huawei.com> - 15.0.0-1
- Update to 15.0.0
* Wed Jan 26 2022 chenchen <chen_aka_jan@163.com> - 12.0.0-1
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/spirv-llvm-translator.git
git@gitee.com:src-openeuler/spirv-llvm-translator.git
src-openeuler
spirv-llvm-translator
spirv-llvm-translator
master

搜索帮助