5 Star 0 Fork 8

src-openEuler/python-pexpect

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-pexpect.spec 3.99 KB
一键复制 编辑 原始数据 按行查看 历史
wk333 提交于 2024-09-02 16:27 . Update to 4.9.0
%global _empty_manifest_terminate_build 0
Name: python-pexpect
Version: 4.9.0
Release: 1
Summary: Pexpect allows easy control of interactive console applications.
License: ISC
URL: https://pexpect.readthedocs.io/
Source0: %{pypi_source pexpect}
BuildArch: noarch
%description
Pexpect is a pure Python module for spawning child applications; controlling
them; and responding to expected patterns in their output. Pexpect works like
Don Libes' Expect. Pexpect allows your script to spawn a child application and
control it as if a human were typing commands.
Pexpect can be used for automating interactive applications such as ssh, ftp,
passwd, telnet, etc. It can be used to a automate setup scripts for duplicating
software package installations on different servers. It can be used for
automated software testing. Pexpect is in the spirit of Don Libes' Expect, but
Pexpect is pure Python.
%package -n python3-pexpect
Summary: Pexpect allows easy control of interactive console applications.
Provides: python-pexpect
BuildRequires: python3-devel python3-setuptools python3-ptyprocess
Requires: python3-ptyprocess
%description -n python3-pexpect
Pexpect is a pure Python module for spawning child applications; controlling
them; and responding to expected patterns in their output. Pexpect works like
Don Libes' Expect. Pexpect allows your script to spawn a child application and
control it as if a human were typing commands.
Pexpect can be used for automating interactive applications such as ssh, ftp,
passwd, telnet, etc. It can be used to a automate setup scripts for duplicating
software package installations on different servers. It can be used for
automated software testing. Pexpect is in the spirit of Don Libes' Expect, but
Pexpect is pure Python.
%package help
Summary: Development documents and examples for pexpect
Provides: python3-pexpect-doc
%description help
Pexpect is a pure Python module for spawning child applications; controlling
them; and responding to expected patterns in their output. Pexpect works like
Don Libes' Expect. Pexpect allows your script to spawn a child application and
control it as if a human were typing commands.
Pexpect can be used for automating interactive applications such as ssh, ftp,
passwd, telnet, etc. It can be used to a automate setup scripts for duplicating
software package installations on different servers. It can be used for
automated software testing. Pexpect is in the spirit of Don Libes' Expect, but
Pexpect is pure Python.
%prep
%autosetup -n pexpect-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pexpect -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Sep 02 2024 wangkai <13474090681@163.com> - 4.9.0-1
- Update to 4.9.0
* Thu Nov 19 2020 leiju <leiju4@huawei.com> - 4.8.0-2
- Add BuildRequiers python3-ptyprocess
* Mon Oct 12 2020 wangxiao <wangxiao65@huawei.com> - 4.8.0-1
- upgrade to 4.8.0, add yaml file
* Thu Oct 17 2019 Lijin Yang <yanglijin@huawei.com> - 4.6-2
- Package init
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/python-pexpect.git
git@gitee.com:src-openeuler/python-pexpect.git
src-openeuler
python-pexpect
python-pexpect
master

搜索帮助