126 Star 0 Fork 12

src-openEuler/python-paste-deploy

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-paste-deploy.spec 3.62 KB
一键复制 编辑 原始数据 按行查看 历史
dongQ 提交于 2024-08-12 14:17 . Update to 3.1.0
%global _empty_manifest_terminate_build 0
Name: python-paste-deploy
Version: 3.1.0
Release: 1
Summary: Load, configure, and compose WSGI applications and servers
License: MIT
URL: https://pylonsproject.org/
Source0: https://files.pythonhosted.org/packages/e3/97/0c4a613ec96a54d21daa7e089178263915554320402e89b4e319436a63cb/PasteDeploy-3.1.0.tar.gz
BuildArch: noarch
%description
This tool provides code to load WSGI applications and servers from URIs. These URIs can refer to Python eggs for INI-style configuration files. Paste Script provides commands to serve applications based on this configuration file.
%package -n python3-paste-deploy
Summary: Load, configure, and compose WSGI applications and servers
Provides: python-paste-deploy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-wheel
BuildRequires: python3-pytest
BuildRequires: python3-pytest-cov
Requires: python3-paste
Requires: python3-sphinx
Requires: python3-pylons-sphinx-themes
Requires: python3-pytest
%description -n python3-paste-deploy
This tool provides code to load WSGI applications and servers from URIs. These URIs can refer to Python eggs for INI-style configuration files. Paste Script provides commands to serve applications based on this configuration file.
%package help
Summary: Load, configure, and compose WSGI applications and servers
Provides: python3-paste-deploy-doc
%description help
This tool provides code to load WSGI applications and servers from URIs. These URIs can refer to Python eggs for INI-style configuration files. Paste Script provides commands to serve applications based on this configuration file.
%prep
%autosetup -n PasteDeploy-%{version}
pushd src
echo `pwd` > absolute_prefix.log
sed -i 's/\//\\\//g' absolute_prefix.log
absolute_prefix=`head -n 1 absolute_prefix.log`
popd
sed -i '/os.path.dirname(egg_info_dir)/a\sys.path.append('"\'$absolute_prefix\/\'"')' ./tests/__init__.py
%build
%py3_build
#cp -r ./src/paste ./tests
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%check
pytest .
%files -n python3-paste-deploy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Aug 12 2024 dongqi <dongqi1@kylinos.cn> - 3.1.0-1
- Update package version to 3.1.0
* Fri Oct 13 2023 wangkai <13474090681@163.com> - 3.0.1-2
- Fix src.rpm name
* Mon Apr 10 2023 Ge Wang <wang--ge@126.com> - 3.0.1-1
- update to version 3.0.1
* Tue Jul 27 2021 OpenStack_SIG <openstack@openeuler.org> - 2.1.1-1
- updata to 2.1.1
* Thu Jul 16 2020 yanglongkang <yanglongkang@huawei.com> - 2.1.0-1
- update package to 2.1.0
* Fri Feb 14 2020 Ruijun Ge <geruijun@huawei.com> - 1.5.2-18
- init package
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/python-paste-deploy.git
git@gitee.com:src-openeuler/python-paste-deploy.git
src-openeuler
python-paste-deploy
python-paste-deploy
master

搜索帮助

D67c1975 1850385 1daf7b77 1850385