代码拉取完成,页面将自动刷新
%global pypi_name jsonschema
%global _description \
jsonschema is JSON Schema validator currently based on http://tools.ietf.org/html/draft-zyp-json-schema-03
Name: python-%{pypi_name}
Version: 4.23.0
Release: 1
Summary: An implementation of JSON Schema validation for Python
License: MIT
URL: http://pypi.python.org/pypi/jsonschema
Source: https://files.pythonhosted.org/packages/source/j/jsonschema/jsonschema-%{version}.tar.gz
BuildArch: noarch
BuildRequires: python3-devel python3-setuptools python3-setuptools_scm
BuildRequires: python3-pbr python3-pip python3-wheel
BuildRequires: python3-hatchling python3-hatch-vcs python3-hatch-fancy-pypi-readme
# test requirements
%bcond_without tests
%if %{without tests}
BuildRequires: python3dist(attrs)
BuildRequires: python3dist(perf)
BuildRequires: python3dist(pyrsistent)
BuildRequires: python3dist(six)
BuildRequires: python3dist(twisted)
%endif
%description %{_description}
%package -n python%{python3_pkgversion}-%{pypi_name}
Summary: An implementation of JSON Schema validation for Python %{python3_version}
%{?python_provide:%python_provide python%{python3_pkgversion}-%{pypi_name}}
%description -n python%{python3_pkgversion}-%{pypi_name} %{_description}
%package_help
%prep
%autosetup -n %{pypi_name}-%{version} -p1
%build
%pyproject_build
%install
%pyproject_install
%if %{without tests}
%check
%pytest
%endif
%files -n python%{python3_pkgversion}-%{pypi_name}
%license COPYING
%{_bindir}/jsonschema
%{python3_sitelib}/%{pypi_name}/
%{python3_sitelib}/%{pypi_name}*.dist-info
%files help
%doc README.rst PKG-INFO
%changelog
* Fri Aug 23 2024 dillon chen <dillon.chen@gmail.com> - 4.23.0-1
- update to 4.23.0
* Wed Jun 12 2024 zeng liwen <zengliwen@kylinos.cn> - 4.22.0-1
- Update to 4.22.0
- Improve best_match (and thereby error messages from jsonschema.validate) in cases where there are multiple sibling errors from applying anyOf / allOf
- (Micro-)optimize equality checks when comparing for JSON Schema equality by first checking for object identity, as == would.
* Fri Jan 26 2024 huangxinhua <huangxinhua12@huawei.com> - 4.21.1-1
- upgrade to version 4.21.1
* Thu Nov 2 2023 Dongxing Wang <dxwangk@isoftstone.com> - 4.19.2-1
- upgrade to version 4.19.2
* Mon Apr 10 2023 zhuofeng <zhuofeng2@huawei.com> - 4.0.1-1
- revert version 4.0.1
* Fri Dec 16 2022 lijian <lijian2@kylinos.cn> - 4.17.3-1
- update to upstream version 4.17.3
* Tue Sep 27 2022 wangjunqi <wangjunqi@kylinos.cn> - 4.0.1-1
- update version to 4.0.1
* Wed Jul 29 2020 jinzhimin<jinzhimin2@huawei.com> - 3.2.0-1
- update to 3.2.0
* Sun Sep 15 2019 openEuler Buildteam <buildteam@openeuler.org> - 2.6.0-6
- Package init
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。