5 Star 0 Fork 7

src-openEuler/python-igraph

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-igraph.spec 3.50 KB
一键复制 编辑 原始数据 按行查看 历史
jiangxinyu 提交于 2024-10-28 14:38 . Update package to version 0.11.6
%global _empty_manifest_terminate_build 0
Name: python-igraph
Version: 0.11.6
Release: 1
Summary: High performance graph data structures and algorithms
License: GPL-2.0-or-later
URL: https://igraph.org/python
Source0: https://files.pythonhosted.org/packages/source/i/igraph/igraph-%{version}.tar.gz
Requires: python3-texttable
Requires: python3-Sphinx
Requires: python3-sphinxbootstrap4theme
Requires: python3-cairocffi
Requires: python3-networkx
Requires: python3-pytest
Requires: python3-networkx
Requires: python3-pytest
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-scipy
%description
Python interface to the igraph high performance graph
library, primarily aimed at complex network research and analysis.
%package -n python3-igraph
Summary: High performance graph data structures and algorithms
Provides: python-igraph = %{version}-%{release}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: cmake
BuildRequires: gcc-g++
%description -n python3-igraph
Python interface to the igraph high performance graph
library, primarily aimed at complex network research and analysis.
%package help
Summary: Development documents and examples for igraph
Provides: python3-igraph-doc
%description help
Python interface to the igraph high performance graph
library, primarily aimed at complex network research and analysis.
%prep
%autosetup -n igraph-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-igraph -f filelist.lst
%dir %{python3_sitearch}/*
%{_includedir}/python3*/igraph/igraphmodule_api.h
%files help
%{_docdir}/*
%changelog
* Mon Oct 28 2024 jiangxinyu <jiangxinyu@kylinos.cn> - 0.11.6-1
- Update package to version 0.11.6
- fix: make sure to compile igrpah with LTO when available
Added Graph.Hypercube() for creating n-dimensional hypercube graphs
* Wed Jun 5 2024 lixiaoyong <lixiaoyong@kylinos.cn> - 0.11.5-1
- Update package to version 0.11.5
Bug fix in libraries.py
Added a prefixattr=... keyword argument to Graph.write_graphml()
The C core of igraph was updated to version 0.10.12
* Tue Feb 20 2024 jiangxinyu <jiangxinyu@kylinos.cn> - 0.11.4-1
- Update package to version 0.11.4
* Fri Sep 15 2023 chenyan <chenyan01@kylinos.cn> - 0.10.8-1
- Update package to version 0.10.8
* Tue Aug 01 2023 zhangchenglin <zhangchenglin@kylinos.cn> - 0.10.6-1
- Update package to version 0.10.6
* Tue Jul 04 2023 chenzixuan <chenzixuan@kylinos.cn> - 0.10.5-1
- Update package to version 0.10.5
* Wed Nov 09 2022 wangjunqi <wangjunqi@kylinos.cn> - 0.10.2-1
- Update package to version 0.10.2
* Mon Jul 18 2022 wanglianguo <wanglianguo@kylinos.cn> - 0.9.11-1
- Package Spec generated
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/python-igraph.git
git@gitee.com:src-openeuler/python-igraph.git
src-openeuler
python-igraph
python-igraph
master

搜索帮助