5 Star 0 Fork 9

src-openEuler/python-icalendar

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-icalendar.spec 3.60 KB
一键复制 编辑 原始数据 按行查看 历史
宋立洋 提交于 2024-11-06 10:45 . upgrade to v5.0.13
%global _empty_manifest_terminate_build 0
Name: python-icalendar
Version: 5.0.13
Release: 1
Summary: iCalendar parser/generator
License: BSD-3-Clause
URL: https://github.com/collective/icalendar
Source0: https://files.pythonhosted.org/packages/source/i/icalendar/icalendar-%{version}.tar.gz
BuildArch: noarch
Requires: python3-dateutil
Requires: python3-pytz
%description
iCalendar specification (RFC 2445) defines calendaring format used\
by many applications (Zimbra, Thunderbird and others). This\
module is a parser/generator of iCalendar files for use with\
Python. It follows the RFC 2445 (iCalendar) specification.\
The aim is to make a package that is fully compliant with RFC 2445,\
well designed, simple to use and well documented.\
%package -n python3-icalendar
Summary: iCalendar parser/generator
Provides: python-icalendar = %{version}-%{release}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-icalendar
iCalendar specification (RFC 2445) defines calendaring format used\
by many applications (Zimbra, Thunderbird and others). This\
module is a parser/generator of iCalendar files for use with\
Python. It follows the RFC 2445 (iCalendar) specification.\
The aim is to make a package that is fully compliant with RFC 2445,\
well designed, simple to use and well documented.\
%package help
Summary: Development documents and examples for icalendar
Provides: python3-icalendar-doc
%description help
development documents and examples for icalendar
%prep
%autosetup -n icalendar-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-icalendar -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Nov 06 2024 songliyang <songliyang@kylinos.cn> - 5.0.13-1
- Update package to version 5.0.13
- add test case for unit prop
- Document how to access the documentation in the browser
- Guide to delete the build folder before testing
- Make documentation build under Python 3.12
* Wed Jun 5 2024 lixiaoyong <lixiaoyong@kylinos.cn> - 5.0.12-1
- Update package to version 5.0.12
Added corpus to fuzzing directory
Add script to convert OSS FUZZ test cases to Python/pytest test cases
Fixed index error in cal.py when attempting to pop from an empty stack
* Tue Feb 20 2024 jiangxinyu <jiangxinyu@kylinos.cn> - 5.0.11-1
- Update package to version 5.0.11
* Tue Jul 04 2023 chenzixuan <chenzixuan@kylinos.cn> - 5.0.7-1
- Update package to version 5.0.7
* Wed Nov 09 2022 wangjunqi <wangjunqi@kylinos.cn> - 5.0.2-1
- Update package to version 5.0.2
* Mon Aug 1 2022 wenzhiwei <wenzhiwei@kylinos.cn> - 4.1.0-1
- Update to 4.1.0
* Tue May 10 2022 xigaoxinyan <xigaoxinyan@h-partners.com> - 4.0.7-2
- License compliance rectification
* Wed Jul 07 2021 liliang <liliang@kylinos.cn> - 4.0.7-1
- Init project
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/python-icalendar.git
git@gitee.com:src-openeuler/python-icalendar.git
src-openeuler
python-icalendar
python-icalendar
master

搜索帮助