5 Star 0 Fork 2

src-openEuler/perl-Math-ConvexHull-MonotoneChain

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
perl-Math-ConvexHull-MonotoneChain.spec 2.13 KB
一键复制 编辑 原始数据 按行查看 历史
%global _empty_manifest_terminate_build 0
Name: perl-Math-ConvexHull-MonotoneChain
Version: 0.01
Release: 2
Summary: Andrew's monotone chain algorithm for finding a convex hull in 2D
License: GPL-1.0-only or Artistic-1.0-Perl
Group: Development/Libraries
URL: https://metacpan.org/dist/Math-ConvexHull-MonotoneChain
Source0: https://cpan.csail.mit.edu/modules/by-module/Math/Math-ConvexHull-MonotoneChain-%{version}.tar.gz
BuildRequires: perl-interpreter
BuildRequires: perl-devel
BuildRequires: perl-generators
BuildRequires: perl(Data::Dumper)
BuildRequires: perl(Test::More)
BuildRequires: perl(ExtUtils::MakeMaker)
%description
This (XS) module optionally exports a single function convex_hull which calculates the convex hull of the input points and returns it. The algorithm is O(n log n) due to having to sort the input list, but should be somewhat faster than a plain Graham's scan (also O(n log n)) in practice since it avoids polar coordinates.
%package help
Summary: Andrew's monotone chain algorithm for finding a convex hull in 2D
Provides: perl-Math-ConvexHull-MonotoneChain
%description help
This (XS) module optionally exports a single function convex_hull which calculates the convex hull of the input points and returns it. The algorithm is O(n log n) due to having to sort the input list, but should be somewhat faster than a plain Graham's scan (also O(n log n)) in practice since it avoids polar coordinates.
%prep
%setup -q -n Math-ConvexHull-MonotoneChain-%{version}
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%install
make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f -name .packlist -delete
find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -exec rm -f {} \;
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
%{_fixperms} $RPM_BUILD_ROOT/*
%check
make test
%files
%doc Changes META.yml
%{perl_vendorarch}/*
%{_mandir}/man3/*
%changelog
* Fri Feb 07 2025 sqfu <dev01203@linx-info.com> - 0.01-2
- drop useless perl(:MODULE_COMPAT) requirement
* Tue Feb 20 2024 woody2918 <wudi1@uniontech.com> - 0.01-1
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/perl-Math-ConvexHull-MonotoneChain.git
git@gitee.com:src-openeuler/perl-Math-ConvexHull-MonotoneChain.git
src-openeuler
perl-Math-ConvexHull-MonotoneChain
perl-Math-ConvexHull-MonotoneChain
master

搜索帮助