代码拉取完成,页面将自动刷新
%global _empty_manifest_terminate_build 0
Name: perl-Math-ConvexHull-MonotoneChain
Version: 0.01
Release: 2
Summary: Andrew's monotone chain algorithm for finding a convex hull in 2D
License: GPL-1.0-only or Artistic-1.0-Perl
Group: Development/Libraries
URL: https://metacpan.org/dist/Math-ConvexHull-MonotoneChain
Source0: https://cpan.csail.mit.edu/modules/by-module/Math/Math-ConvexHull-MonotoneChain-%{version}.tar.gz
BuildRequires: perl-interpreter
BuildRequires: perl-devel
BuildRequires: perl-generators
BuildRequires: perl(Data::Dumper)
BuildRequires: perl(Test::More)
BuildRequires: perl(ExtUtils::MakeMaker)
%description
This (XS) module optionally exports a single function convex_hull which calculates the convex hull of the input points and returns it. The algorithm is O(n log n) due to having to sort the input list, but should be somewhat faster than a plain Graham's scan (also O(n log n)) in practice since it avoids polar coordinates.
%package help
Summary: Andrew's monotone chain algorithm for finding a convex hull in 2D
Provides: perl-Math-ConvexHull-MonotoneChain
%description help
This (XS) module optionally exports a single function convex_hull which calculates the convex hull of the input points and returns it. The algorithm is O(n log n) due to having to sort the input list, but should be somewhat faster than a plain Graham's scan (also O(n log n)) in practice since it avoids polar coordinates.
%prep
%setup -q -n Math-ConvexHull-MonotoneChain-%{version}
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%install
make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f -name .packlist -delete
find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -exec rm -f {} \;
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
%{_fixperms} $RPM_BUILD_ROOT/*
%check
make test
%files
%doc Changes META.yml
%{perl_vendorarch}/*
%{_mandir}/man3/*
%changelog
* Fri Feb 07 2025 sqfu <dev01203@linx-info.com> - 0.01-2
- drop useless perl(:MODULE_COMPAT) requirement
* Tue Feb 20 2024 woody2918 <wudi1@uniontech.com> - 0.01-1
- Package init
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。