7 Star 0 Fork 27

src-openEuler/kmod

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
kmod.spec 3.49 KB
一键复制 编辑 原始数据 按行查看 历史
zhangyaqi 提交于 2024-05-10 10:17 . clear file memory if map fails
Name: kmod
Version: 30
Release: 4
Summary: Kernel module management
# GPLv2+ is used by programs, LGPLv2+ is used for libraries.
License: GPLv2+ and LGPLv2+
URL: http://git.kernel.org/?p=utils/kernel/kmod/kmod.git;a=summary
Source0: https://www.kernel.org/pub/linux/utils/kernel/kmod/%{name}-%{version}.tar.xz
Source1: weak-modules
Source2: depmod.conf.dist
Source3: kmod.changes
BuildRequires: gcc chrpath zlib-devel xz-devel libxslt openssl-devel libtool gtk-doc
Provides: module-init-tools = 4.0-1
Provides: /sbin/modprobe
Patch: 0001-Module-replace-the-module-with-new-module.patch
Patch: 0002-Module-suspend-the-module-by-rmmod-r-option.patch
Patch: 0003-clear-file-memory-if-map-fails.patch
%description
The kmod package provides several commands to manage the kernel modules,
such as insmod to load and rmmod to unload the modules.
%package libs
Summary: Libraries to handle kernel module loading and unloading
License: LGPLv2+
%description libs
The kmod-libs package provides runtime libraries for any application that
wishes to load or unload Linux kernel modules from the running system.
%package devel
Summary: Header files for kmod development
Requires: %{name} = %{version}-%{release} %{name}-libs
%description devel
The kmod-devel package provides header files used for loading or unloading
kernel modules.
%package -n python3-kmod
Summary: Python3 bindings for kmod/libkmod.
BuildRequires: python3 python3-devel python3-Cython kmod-devel kmod-libs
Requires: python3
%description -n python3-kmod
python3-kmod is a Python3 wrapper module for libkmod, exposing common
module operations: listing installed modules, modprobe, and rmmod.
%package help
Summary: Documents and man pages for the kmod
Requires: man info
%description help
The kmod-help package provides several documents and the man pages to help
developers to understand the kmod.
%prep
%autosetup -n %{name}-%{version} -p1
%build
# Reinitialize libtool to remove Rpath
autoreconf -vif
%configure --with-openssl --with-zlib --with-xz --enable-python
%make_build
%install
%make_install
rm -f %{buildroot}%{python3_sitearch}/kmod/*.la
pushd $RPM_BUILD_ROOT/%{_mandir}/man5
ln -s modprobe.d.5.gz modprobe.conf.5.gz
popd
mkdir -p $RPM_BUILD_ROOT%{_sbindir}
for i in $RPM_BUILD_ROOT%{_sbindir}/modprobe $RPM_BUILD_ROOT%{_sbindir}/modinfo $RPM_BUILD_ROOT%{_sbindir}/insmod \
$RPM_BUILD_ROOT%{_sbindir}/rmmod $RPM_BUILD_ROOT%{_sbindir}/depmod $RPM_BUILD_ROOT%{_sbindir}/lsmod
do
ln -sf ../bin/kmod $i
done
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/modprobe.d
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/depmod.d
mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/modprobe.d
mkdir -p $RPM_BUILD_ROOT/sbin
install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/weak-modules
install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/depmod.d/dist.conf
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%exclude %{_libdir}/*.la
%dir %{_sysconfdir}/*.d
%dir %{_prefix}/lib/modprobe.d
%{_bindir}/kmod
%{_sbindir}/*
%{_datadir}/bash-completion/
%{_sysconfdir}/depmod.d/dist.conf
%files libs
%{!?_licensedir:%global license %%doc}
%license COPYING
%{_libdir}/libkmod.so.*
%files devel
%{_includedir}/libkmod.h
%{_libdir}/pkgconfig/libkmod.pc
%{_libdir}/libkmod.so
%files -n python3-kmod
%{python3_sitearch}/kmod/
%files help
%attr(0644,root,root) %{_mandir}/man5/*.5*
%attr(0644,root,root) %{_mandir}/man8/*.8*
%doc TODO NEWS README.md
%include %{SOURCE3}
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/kmod.git
git@gitee.com:src-openeuler/kmod.git
src-openeuler
kmod
kmod
master

搜索帮助

D67c1975 1850385 1daf7b77 1850385