9 Star 0 Fork 2

src-openEuler/htmlcxx

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
htmlcxx.spec 1.91 KB
一键复制 编辑 原始数据 按行查看 历史
Venland 提交于 2023-08-15 17:28 . fix compile fail
Name: htmlcxx
Version: 0.86
Release: 2
License: LGPLv2 and GPLv2+ and ASL 2.0 and MIT
Summary: A simple non-validating CSS1 and HTML parser for C++
Url: http://htmlcxx.sourceforge.net/
Source0: http://sourceforge.net/projects/htmlcxx/files/htmlcxx/%{version}/%{name}-%{version}.tar.gz
BuildRequires: gcc-c++
BuildRequires: chrpath
%description
htmlcxx is a simple non-validating html parser library for C++.
It allows to fully dump the original html document, character by character,
from the parse tree. It also has an intuitive tree traversal API.
%package devel
Summary: Headers and Static Library for htmlcxx
BuildRequires: pkgconfig
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
The htmlcxx-devel package contains libraries and header files for
developing applications that use htmlcxx.
%prep
%setup -q
# convert to utf8 due rpmlint warning W: file-not-utf8 /usr/share/doc/htmlcxx/AUTHORS
# convert to utf8 due rpmlint warning W: file-not-utf8 /usr/share/doc/htmlcxx/README
iconv -f iso8859-1 -t utf-8 AUTHORS > AUTHORS.conv && mv -f AUTHORS.conv AUTHORS
iconv -f iso8859-1 -t utf-8 README > README.conv && mv -f README.conv README
%build
CC="$CC -std=gnu89"
export CXXFLAGS="-std=c++14 $RPM_OPT_FLAGS"
%configure --disable-static --enable-shared
make %{?_smp_mflags}
%install
make install DESTDIR=%{buildroot}
chrpath --delete %{buildroot}%{_bindir}/htmlcxx
# remove all '*.la' files
find %{buildroot} -name '*.la' -exec rm -f {} ';'
%check
make check
%ldconfig_scriptlets -n %{name}
%files
%doc AUTHORS ChangeLog README
%license COPYING LGPL_V2 ASF-2.0
%{_bindir}/*
%{_datadir}/*
%{_libdir}/*.so.*
%files devel
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/pkgconfig/%{name}.pc
%changelog
* Tue Aug 15 2023 leeffo <liweiganga@uniontech.com> - 0.86-2
- fix compile fail
* Mon Jul 25 2022 loong_C <loong_c@yeah.net> - 0.86-1
- init package
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/htmlcxx.git
git@gitee.com:src-openeuler/htmlcxx.git
src-openeuler
htmlcxx
htmlcxx
master

搜索帮助