12 Star 0 Fork 12

src-openEuler/cpp-httplib

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
cpp-httplib.spec 2.45 KB
一键复制 编辑 原始数据 按行查看 历史
Funda Wang 提交于 2024-09-19 12:10 . 0.18.0
Name: cpp-httplib
Version: 0.18.0
Release: 1
Summary: A C++ header-only HTTP/HTTPS server and client library
License: MIT
URL: https://github.com/yhirose/cpp-httplib
Source0: https://github.com/yhirose/cpp-httplib/archive/refs/tags/v%{version}.tar.gz
BuildRequires: gcc-c++
BuildRequires: meson >= 0.62.0
BuildRequires: pkgconfig(libcurl)
BuildRequires: pkgconfig(gtest)
BuildRequires: pkgconfig(libbrotlicommon)
BuildRequires: pkgconfig(libbrotlidec)
BuildRequires: pkgconfig(libbrotlienc)
BuildRequires: pkgconfig(openssl) >= 3.0.0
BuildRequires: pkgconfig(zlib)
BuildRequires: /usr/bin/openssl
BuildRequires: /usr/bin/python3
%description
A C++11 single-file header-only cross platform HTTP/HTTPS library.
It's extremely easy to setup. Just include httplib.h file in your code!
%package devel
Summary: A C++11 single-file header-only cross platform HTTP/HTTPS library
Requires: %{name}%{?_isa} = %{version}-%{release}
Conflicts: %{name} < 0.18.0
%description devel
A C++11 single-file header-only cross platform HTTP/HTTPS library.
It's extremely easy to setup. Just include the httplib.h file in your code!
NOTE: This is a multi-threaded 'blocking' HTTP library.
If you are looking for a 'non-blocking' library, this is not the one that you want.
Development files only.
%prep
%autosetup -p1 -n %{name}-%{version}
%build
%meson -Dcpp-httplib_compile=true -Dcpp-httplib_test=true \
--buildtype=release
%meson_build
%install
%meson_install
%check
export GTEST_FILTER='_Online$'
%meson_test
%files
%license LICENSE
%{_libdir}/lib%{name}.so.*
%files devel
%doc README.md example
%{_includedir}/httplib.h
%{_libdir}/lib%{name}.so
%{_libdir}/pkgconfig/%{name}.pc
%changelog
* Thu Sep 19 2024 Funda Wang <fundawang@yeah.net> - 0.18.0-1
- update to 0.18.0
* Mon Mar 11 2024 xu_ping <707078654@qq.com> - 0.15.3-1
- Upgrade version to 0.15.3
* Wed Sep 27 2023 Chenxi Mao <chenxi.mao@suse.com> - 0.14.0-2
- Add openssl to build require list to fix build error
* Thu Sep 14 2023 liyanan <thistleslyn@163.com> - 0.14.0-1
- update to 0.14.0
* Tue Jun 13 2023 yaoxin <yao_xin001@hoperun.com> - 0.12.4-1
- Update to 0.12.4 for fix CVE-2023-26130
* Tue Aug 16 2022 jinzhiguang <jinzhiguang@kylinos.cn> - 0.11.1-1
- update to 0.11.1
* Wed Mar 03 2021 Liu Gang <liuganga@uniontech.com>
- cp httplib.h to doc dir for make example
* Mon Oct 12 2020 liqingqing_1229 <liqingqing3@huawei.com>
- update source0's url
* Sun Mar 29 2020 Wei Xiong <myeuler@163.com>
- Package init
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/cpp-httplib.git
git@gitee.com:src-openeuler/cpp-httplib.git
src-openeuler
cpp-httplib
cpp-httplib
master

搜索帮助