代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/python-zope-interface 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%global _empty_manifest_terminate_build 0
Name: python-zope-interface
Version: 5.2.0
Release: 1
Summary: Interfaces for Python
License: ZPL 2.1
URL: https://github.com/zopefoundation/zope.interface
Source0: https://github.com/zopefoundation/zope.interface/archive/%{version}.tar.gz
%description
This package is intended to be independently reusable in any Python project.
This package provides an implementation of "object interfaces" for Python.
Interfaces are a mechanism for labeling objects as conforming to a given
API or contract. So, this package can be considered as implementation of
the `Design By Contract`_ methodology support in Python.
%package -n python3-zope-interface
Summary: Interfaces for Python
Provides: python-zope-interface
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-zope-interface
This package is intended to be independently reusable in any Python project.
This package provides an implementation of "object interfaces" for Python.
Interfaces are a mechanism for labeling objects as conforming to a given
API or contract. So, this package can be considered as implementation of
the `Design By Contract`_ methodology support in Python.
%package help
Summary: Development documents and examples for zope.interface
Provides: python3-zope-interface-doc
%description help
Development documents and examples for zope.interface.
%prep
%autosetup -n zope.interface-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-zope-interface -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_pkgdocdir}
%changelog
* Thu Dec 17 2020 Python_Bot <Python_Bot@openeuler.org> - 5.2.0-1
- Update to 5.2.0
* Wed Aug 5 2020 zhangjiapeng <zhangjiapeng9@huawei.com> - 4.7.2-1
- Upgrade to 4.7.2 to remove deprecated use of setuptools features
* Wed Feb 12 2020 openEuler Buildteam <buildteam@openeuler.org> - 4.5.0-3
- Package init
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。