1 Star 0 Fork 12

liusheng/python-wsgi-intercept

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-wsgi-intercept.spec 3.41 KB
一键复制 编辑 原始数据 按行查看 历史
huangtianhua 提交于 2021-02-20 05:08 . Fixes building error
%global _empty_manifest_terminate_build 0
Name: python-wsgi-intercept
Version: 1.9.2
Release: 3
Summary: wsgi_intercept installs a WSGI application in place of a real URI for testing.
License: MIT License
URL: https://github.com/cdent/wsgi-intercept
Source0: https://files.pythonhosted.org/packages/8b/a2/2dec56a11e174d3ad6397a01118f6d7eaf3cc0fd3387f1b60d0f9df6ff96/wsgi_intercept-1.9.2.tar.gz
BuildArch: noarch
Requires: python3-six
Requires: python3-sphinx
Requires: python3-pytest
Requires: python3-httplib2
Requires: python3-requests
Requires: python3-urllib3
%description
Testing a WSGI application sometimes involves starting a server at a
local host and port, then pointing your test code to that address.
Instead, this library lets you intercept calls to any specific host/port
combination and redirect them into a `WSGI application`_ importable by
your test program. Thus, you can avoid spawning multiple processes or
threads to test your Web app.
%package -n python3-wsgi-intercept
Summary: wsgi_intercept installs a WSGI application in place of a real URI for testing.
Provides: python-wsgi-intercept, python3-wsgi_intercept
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-pbr
%description -n python3-wsgi-intercept
Testing a WSGI application sometimes involves starting a server at a
local host and port, then pointing your test code to that address.
Instead, this library lets you intercept calls to any specific host/port
combination and redirect them into a `WSGI application`_ importable by
your test program. Thus, you can avoid spawning multiple processes or
threads to test your Web app.
%package help
Summary: Development documents and examples for wsgi-intercept
Provides: python3-wsgi-intercept-doc
%description help
Testing a WSGI application sometimes involves starting a server at a
local host and port, then pointing your test code to that address.
Instead, this library lets you intercept calls to any specific host/port
combination and redirect them into a `WSGI application`_ importable by
your test program. Thus, you can avoid spawning multiple processes or
threads to test your Web app.
%prep
%autosetup -n wsgi_intercept-1.9.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-wsgi-intercept -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Feb 20 2021 huangtianhua <huangtianhua223@gmail.com>
- Fix build error
* Thu Jan 28 2021 zhangy <zhangy1317@foxmail.com>
- Add buildrequires
* Thu Dec 31 2020 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/sean-lau/python-wsgi-intercept.git
git@gitee.com:sean-lau/python-wsgi-intercept.git
sean-lau
python-wsgi-intercept
python-wsgi-intercept
master

搜索帮助