代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/python-setproctitle 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%global _empty_manifest_terminate_build 0
Name: python-setproctitle
Version: 1.2.1
Release: 1
Summary: A Python module to customize the process title
License: BSD
URL: https://github.com/dvarrazzo/py-setproctitle
Source0: https://files.pythonhosted.org/packages/a7/e1/e76b903af017cc4a99f823b5e4235c1136dcca6902e6b7ee4d545958ba8c/setproctitle-1.2.1.tar.gz
Requires: python3-pytest
%description
The setproctitle module allows a process to change its title (as displayed
by system tools such as ps and top).
Changing the title is mostly useful in multi-process systems, for example
when a master process is forked: changing the children's title allows to
identify the task each process is busy with. The technique is used by
PostgreSQL and the OpenSSH Server for example.
The procedure is hardly portable across different systems. PostgreSQL provides
a good multi-platform implementation: this module is a Python wrapper
around PostgreSQL code.
%package -n python3-setproctitle
Summary: A Python module to customize the process title
Provides: python-setproctitle
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-setproctitle
The setproctitle module allows a process to change its title (as displayed
by system tools such as ps and top).
Changing the title is mostly useful in multi-process systems, for example
when a master process is forked: changing the children's title allows to
identify the task each process is busy with. The technique is used by
PostgreSQL and the OpenSSH Server for example.
The procedure is hardly portable across different systems. PostgreSQL provides
a good multi-platform implementation: this module is a Python wrapper
around PostgreSQL code.
%package help
Summary: Development documents and examples for setproctitle
Provides: python3-setproctitle-doc
%description help
The setproctitle module allows a process to change its title (as displayed
by system tools such as ps and top).
Changing the title is mostly useful in multi-process systems, for example
when a master process is forked: changing the children's title allows to
identify the task each process is busy with. The technique is used by
PostgreSQL and the OpenSSH Server for example.
The procedure is hardly portable across different systems. PostgreSQL provides
a good multi-platform implementation: this module is a Python wrapper
around PostgreSQL code.
%prep
%autosetup -n setproctitle-1.2.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-setproctitle -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Jan 06 2021 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。