代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/python-keystonemiddleware 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%global _empty_manifest_terminate_build 0
Name: python-keystonemiddleware
Version: 4.21.0
Release: 1
Summary: Middleware for OpenStack Identity
License: Apache-2.0
URL: https://docs.openstack.org/developer/keystonemiddleware/
Source0: https://files.pythonhosted.org/packages/00/e5/b07bb783a5ec5a4976c1fdf88115f18fea9fa71fdf2f23c00a04ebc66a20/keystonemiddleware-4.21.0.tar.gz
BuildArch: noarch
%description
========================
Team and repository tags
========================
.. image:: https://governance.openstack.org/badges/keystonemiddleware.svg
:target: https://governance.openstack.org/reference/tags/index.html
.. Change things from this point on
Middleware for the OpenStack Identity API (Keystone)
====================================================
.. image:: https://img.shields.io/pypi/v/keystonemiddleware.svg
:target: https://pypi.python.org/pypi/keystonemiddleware/
:alt: Latest Version
.. image:: https://img.shields.io/pypi/dm/keystonemiddleware.svg
:target: https://pypi.python.org/pypi/keystonemiddleware/
:alt: Downloads
This package contains middleware modules designed to provide authentication and
authorization features to web services other than `Keystone
<https://github.com/openstack/keystone>`. The most prominent module is
``keystonemiddleware.auth_token``. This package does not expose any CLI or
Python API features.
For information on contributing, see ``CONTRIBUTING.rst``.
* License: Apache License, Version 2.0
* Documentation: https://docs.openstack.org/keystonemiddleware/latest/
* Source: https://git.openstack.org/cgit/openstack/keystonemiddleware
* Bugs: https://bugs.launchpad.net/keystonemiddleware
For any other information, refer to the parent project, Keystone:
https://github.com/openstack/keystone
%package -n python2-keystonemiddleware
Summary: Middleware for OpenStack Identity
Provides: python-keystonemiddleware
BuildRequires: python2-devel
BuildRequires: python2-setuptools
Requires: python2-keystoneauth1
Requires: python2-oslo-cache
Requires: python2-oslo-config
Requires: python2-oslo-context
Requires: python2-oslo-i18n
Requires: python2-oslo-log
Requires: python2-oslo-serialization
Requires: python2-oslo-utils
Requires: python2-pbr
Requires: python2-pycadf
Requires: python2-keystoneclient
Requires: python2-requests
Requires: python2-six
Requires: python2-WebOb
Requires: python2-oslo-messaging
%description -n python2-keystonemiddleware
========================
Team and repository tags
========================
.. image:: https://governance.openstack.org/badges/keystonemiddleware.svg
:target: https://governance.openstack.org/reference/tags/index.html
.. Change things from this point on
Middleware for the OpenStack Identity API (Keystone)
====================================================
.. image:: https://img.shields.io/pypi/v/keystonemiddleware.svg
:target: https://pypi.python.org/pypi/keystonemiddleware/
:alt: Latest Version
.. image:: https://img.shields.io/pypi/dm/keystonemiddleware.svg
:target: https://pypi.python.org/pypi/keystonemiddleware/
:alt: Downloads
This package contains middleware modules designed to provide authentication and
authorization features to web services other than `Keystone
<https://github.com/openstack/keystone>`. The most prominent module is
``keystonemiddleware.auth_token``. This package does not expose any CLI or
Python API features.
For information on contributing, see ``CONTRIBUTING.rst``.
* License: Apache License, Version 2.0
* Documentation: https://docs.openstack.org/keystonemiddleware/latest/
* Source: https://git.openstack.org/cgit/openstack/keystonemiddleware
* Bugs: https://bugs.launchpad.net/keystonemiddleware
For any other information, refer to the parent project, Keystone:
https://github.com/openstack/keystone
%package help
Summary: Development documents and examples for keystonemiddleware
Provides: python2-keystonemiddleware-doc
%description help
========================
Team and repository tags
========================
.. image:: https://governance.openstack.org/badges/keystonemiddleware.svg
:target: https://governance.openstack.org/reference/tags/index.html
.. Change things from this point on
Middleware for the OpenStack Identity API (Keystone)
====================================================
.. image:: https://img.shields.io/pypi/v/keystonemiddleware.svg
:target: https://pypi.python.org/pypi/keystonemiddleware/
:alt: Latest Version
.. image:: https://img.shields.io/pypi/dm/keystonemiddleware.svg
:target: https://pypi.python.org/pypi/keystonemiddleware/
:alt: Downloads
This package contains middleware modules designed to provide authentication and
authorization features to web services other than `Keystone
<https://github.com/openstack/keystone>`. The most prominent module is
``keystonemiddleware.auth_token``. This package does not expose any CLI or
Python API features.
For information on contributing, see ``CONTRIBUTING.rst``.
* License: Apache License, Version 2.0
* Documentation: https://docs.openstack.org/keystonemiddleware/latest/
* Source: https://git.openstack.org/cgit/openstack/keystonemiddleware
* Bugs: https://bugs.launchpad.net/keystonemiddleware
For any other information, refer to the parent project, Keystone:
https://github.com/openstack/keystone
%prep
%autosetup -n keystonemiddleware-4.21.0
%build
%py2_build
%install
%py2_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python2-keystonemiddleware -f filelist.lst
%dir %{python2_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 07 2021 OpenStack_SIG <openstack@openeuler.org>
- Package Spec generated
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。