1 Star 0 Fork 12

liusheng/python-hacking

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-hacking.spec 3.27 KB
一键复制 编辑 原始数据 按行查看 历史
zhangy1317 提交于 2021-01-30 15:21 . Add BuildRequires
%global _empty_manifest_terminate_build 0
Name: python-hacking
Version: 4.0.0
Release: 2
Summary: OpenStack Hacking Guideline Enforcement
License: Apache-2.0
URL: https://docs.openstack.org/hacking/latest/
Source0: https://files.pythonhosted.org/packages/cd/6a/c4885e716d6a9f2263be3c541937d0a8a1bcc6e19cb3e35af8b960f70380/hacking-4.0.0.tar.gz
BuildArch: noarch
Requires: python3-subunit
Requires: python3-stestr
Requires: python3-testscenarios
Requires: python3-testtools
Requires: python3-flake8
Requires: python3-flake8-docstrings
Requires: python3-coverage
Requires: python3-ddt
Requires: python3-eventlet
Requires: python3-fixtures
Requires: python3-mock
%description
hacking is a set of flake8 plugins that test and enforce the
`OpenStack StyleGuide <https://docs.openstack.org/hacking/latest/user/hacking.html#styleguide>`_
Hacking pins its dependencies, as a new release of some dependency can break
hacking based gating jobs. This is because new versions of dependencies can
introduce new rules, or make existing rules stricter.
%package -n python3-hacking
Summary: OpenStack Hacking Guideline Enforcement
Provides: python-hacking
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-pbr
%description -n python3-hacking
hacking is a set of flake8 plugins that test and enforce the
`OpenStack StyleGuide <https://docs.openstack.org/hacking/latest/user/hacking.html#styleguide>`_
Hacking pins its dependencies, as a new release of some dependency can break
hacking based gating jobs. This is because new versions of dependencies can
introduce new rules, or make existing rules stricter.
%package help
Summary: Development documents and examples for hacking
Provides: python3-hacking-doc
%description help
hacking is a set of flake8 plugins that test and enforce the
`OpenStack StyleGuide <https://docs.openstack.org/hacking/latest/user/hacking.html#styleguide>`_
Hacking pins its dependencies, as a new release of some dependency can break
hacking based gating jobs. This is because new versions of dependencies can
introduce new rules, or make existing rules stricter.
%prep
%autosetup -n hacking-4.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-hacking -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sat Jan 30 2021 zhangy <zhangy1317@foxmail.com>
- Add buildrequires
* Fri Nov 20 2020 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/sean-lau/python-hacking.git
git@gitee.com:sean-lau/python-hacking.git
sean-lau
python-hacking
python-hacking
master

搜索帮助