1 Star 0 Fork 4

liusheng/python-cachez

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-cachez.spec 2.45 KB
一键复制 编辑 原始数据 按行查看 历史
chenyanpanHW 提交于 2021-07-30 23:20 . delete -S git from %autosetup
%global _empty_manifest_terminate_build 0
Name: python-cachez
Version: 0.1.2
Release: 3
Summary: Cache decorator for global or instance level memoize.
License: Apache-2.0
URL: http://github.com/jealous/cachez
Source0: https://files.pythonhosted.org/packages/c5/3e/67c7ce94d258cf0070f62aed6ef705ce83314e7e72eb40d881b5cc90642a/cachez-0.1.2.tar.gz
BuildArch: noarch
%description
Cache decorator for global or instance level memoize.
%package -n python3-cachez
Summary: Cache decorator for global or instance level memoize.
Provides: python-cachez
# Base build requires
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-wheel
BuildRequires: python3-pytest
BuildRequires: python3-hamcrest
%description -n python3-cachez
Cache decorator for global or instance level memoize.
%package help
Summary: Cache decorator for global or instance level memoize.
Provides: python3-cachez-doc
%description help
Cache decorator for global or instance level memoize.
%prep
%autosetup -n cachez-0.1.2 -p1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%check
pytest
%files -n python3-cachez -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jul 30 2021 chenyanpanHW <chenyanpan@huawei.com> - 0.1.2-3
- DESC: delete -S git from %autosetup
* Wed Jul 28 2021 OpenStack_SIG <openstack@openeuler.org> - 0.1.2-2
- Fix check error
* Mon Jul 26 2021 OpenStack_SIG <openstack@openeuler.org> - 0.1.2-1
- Package Spec generate
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/sean-lau/python-cachez.git
git@gitee.com:sean-lau/python-cachez.git
sean-lau
python-cachez
python-cachez
master

搜索帮助