1 Star 0 Fork 4

que61116836/perl-Regexp-Stringify

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
perl-Regexp-Stringify.spec 2.81 KB
一键复制 编辑 原始数据 按行查看 历史
que61116836 提交于 2021-07-22 05:56 . 提交perl-Regexp-Stringify
%global _empty_manifest_terminate_build 0
Name: perl-Regexp-Stringify
Version: 0.06
Release: 1
Summary: Regexp::Stringify Perl module
License: GPL+ or Artistic
Group: Development/Libraries
URL: http://search.cpan.org/dist/Regexp-Stringify/
Source0: http://www.cpan.org/authors/id/P/PE/PERLANCAR/Regexp-Stringify-%{version}.tar.gz
BuildArch: noarch
BuildRequires: perl >= 0:5.010001
BuildRequires: perl-generators
BuildRequires: perl(Exporter)
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(File::Spec)
BuildRequires: perl(re)
BuildRequires: perl(strict)
BuildRequires: perl(Test::More) >= 0.98
BuildRequires: perl(warnings)
Requires: perl(Exporter)
Requires: perl(re)
Requires: perl(strict)
Requires: perl(warnings)
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description
use Regexp::Stringify qw(stringify_regexp); $str =
stringify_regexp(regexp=>qr/a/i); # '(^i:a)' $str =
stringify_regexp(regexp=>qr/a/i, with_qr=>1); # 'qr(a)i' $str =
stringify_regexp(regexp=>qr/a/i, plver=>5.010); # '(?:(?i-)a)' $str
= stringify_regexp(regexp=>qr/a/ui, plver=>5.010); # '(?:(?i-)a)'
%package help
Summary : Regexp::Stringify Perl module
Provides: perl-Regexp-Stringify-doc
%description help
use Regexp::Stringify qw(stringify_regexp); $str =
stringify_regexp(regexp=>qr/a/i); # '(^i:a)' $str =
stringify_regexp(regexp=>qr/a/i, with_qr=>1); # 'qr(a)i' $str =
stringify_regexp(regexp=>qr/a/i, plver=>5.010); # '(?:(?i-)a)' $str
= stringify_regexp(regexp=>qr/a/ui, plver=>5.010); # '(?:(?i-)a)'
%prep
%setup -q -n Regexp-Stringify-%{version}
%build
export PERL_MM_OPT=""
%{__perl} Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%install
export PERL_MM_OPT=""
rm -rf $RPM_BUILD_ROOT
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
%{_fixperms} $RPM_BUILD_ROOT/*
pushd %{buildroot}
touch filelist.lst
if [ -d usr/bin ];then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ];then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ];then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib ];then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
popd
mv %{buildroot}/filelist.lst .
%check
make test
%clean
rm -rf $RPM_BUILD_ROOT
%files -f filelist.lst
%defattr(-,root,root,-)
%doc Changes dist.ini LICENSE META.json README weaver.ini
%{perl_vendorlib}/*
%files help
%{_mandir}/*
%changelog
* Wed Jul 21 2021 Perl_Bot <Perl_Bot@openeuler.org> 0.06-1
- Specfile autogenerated by Perl_Bot
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/que61116836/perl-Regexp-Stringify.git
git@gitee.com:que61116836/perl-Regexp-Stringify.git
que61116836
perl-Regexp-Stringify
perl-Regexp-Stringify
master

搜索帮助