1 Star 0 Fork 7

mxh/python-restfly

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-restfly.spec 2.56 KB
一键复制 编辑 原始数据 按行查看 历史
mxh 提交于 2024-08-06 18:34 . Upgrade to version 1.4.0
%global _empty_manifest_terminate_build 0
Name: python-restfly
Version: 1.4.0
Release: 1
Summary: A simple framework for building RESTful API libraries
License: MIT
URL: https://github.com/stevemcgrath/restfly
Source0: https://files.pythonhosted.org/packages/2a/3d/ddabaf0d62c671c147ec5cb01269e6bf9801d25dfc2e9a1d768b8c110901/restfly-1.4.0.tar.gz
BuildArch: noarch
%global _description\
RESTfly(pronounced restfully) is a framework for building libraries to\
easily interact with RESTful APIs.\
RESTfly is a simple library designed to provide the scaffolding to make API\
interaction libraries for just about any RESTful API. With an emphasis on\
simplicity and readability of the resulting library code thats written, the\
idea here is provide something that is not only useful for folks to use, but\
can also serve as a reference implimentation of the given APIs.\
for more information, please refer to the documentation at \
https://restfly.readthedocs.io
%description %_description
%package -n python3-restfly
Summary: A simple framework for building RESTful API libraries
Provides: python-restfly
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-restfly %_description
%package help
Summary: Development documents and examples for restfly
Provides: python3-restfly-doc
%description help %_description
%prep
%autosetup -n restfly-1.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-restfly -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Aug 06 2024 muxiaohui <muxiaohui@kylinos.cn> - 1.4.0-1
- Update package to version 1.4.0
- RESTfly now has typing support
* Thu Sep 03 2020 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/mxh111999/python-restfly.git
git@gitee.com:mxh111999/python-restfly.git
mxh111999
python-restfly
python-restfly
master

搜索帮助