1 Star 0 Fork 6

mxh/python-Flask-Limiter

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-flask-limiter.spec 2.55 KB
一键复制 编辑 原始数据 按行查看 历史
mxh 提交于 2024-08-03 16:12 . Upgrade package to version 3.5.1
%global _empty_manifest_terminate_build 0
Name: python-Flask-Limiter
Version: 3.5.1
Release: 1
Summary: Rate limiting for flask applications
License: MIT
URL: https://flask-limiter.readthedocs.org
Source0: https://files.pythonhosted.org/packages/ad/62/24440d89655fefa01f3dd7614d95222b4c1f65e5d1dbf4744c3609300c4a/Flask-Limiter-3.5.1.tar.gz
BuildArch: noarch
%description
Flask-Limiter provides rate limiting features to flask routes.
%package -n python3-Flask-Limiter
Summary: Rate limiting for flask applications
Provides: python-Flask-Limiter = %{version}-%{release}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
Requires: python3-limits
Requires: python3-flask
Requires: python3-six
%description -n python3-Flask-Limiter
Flask-Limiter provides rate limiting features to flask routes.
%package help
Summary: Development documents and examples for Flask-Limiter
Provides: python3-Flask-Limiter-doc
%description help
Development documents and examples for Flask-Limiter
%prep
%autosetup -n Flask-Limiter-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Flask-Limiter -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sat Aug 03 2024 muxiaohui <muxiaohui@kylinos.cn> - 3.5.1-1
- Update package to version 3.5.1
- Update development dependencies
- Update CI compatibility matrix
- Use ruff for all linting
* Fri Oct 27 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 3.5.0-1
- Update package to version 3.5.0
* Tue Jun 20 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 3.3.1-1
- Update package to version 3.3.1
* Wed May 17 2023 wulei <wu_lei@hoperun.com> - 2.9.2-1
- Update to 2.9.2
* Mon Feb 08 2021 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/mxh111999/python-Flask-Limiter.git
git@gitee.com:mxh111999/python-Flask-Limiter.git
mxh111999
python-Flask-Limiter
python-Flask-Limiter
master

搜索帮助