1 Star 0 Fork 11

markeryang/python-decorator

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-decorator.spec 1.76 KB
一键复制 编辑 原始数据 按行查看 历史
chengquan 提交于 2019-12-31 18:37 . update source code
%global _name decorator
%global _description The goal of the decorator module is to make it easy to define signature-preserving \
function decorators and decorator factories. It also includes an implementation of multiple dispatch and \
other niceties (please check the docs).
Name: python-%{_name}
Version: 4.3.0
Release: 3
Summary: Simplify the signature-preserving function decorators and decorator factories
License: BSD
URL: https://github.com/micheles/decorator
Source0: https://github.com/micheles/decorator/archive/%{version}.tar.gz#/%{_name}-%{version}.tar.gz
BuildArch: noarch
%description
%{_description}
%package -n python2-decorator
Summary: %{summary} in python2
BuildRequires: python2-devel python2-setuptools
%{?python_provide:%python_provide python2-decorator}
%description -n python2-decorator
%{_description}
%package -n python3-decorator
Summary: %{summary} in python3
BuildRequires: python3-devel python3-setuptools
%{?python_provide:%python_provide python3-decorator}
%description -n python3-decorator
%{_description}
%package_help
%prep
%autosetup -n %{_name}-%{version} -p1
%build
%py2_build
%py3_build
%install
%py2_install
%py3_install
%check
%{__python2} setup.py test
%{__python3} setup.py test
%files -n python2-%{_name}
%doc docs/README.rst
%license LICENSE.txt
%{python2_sitelib}/*
%files -n python3-%{_name}
%doc docs/README.rst
%license LICENSE.txt
%{python3_sitelib}/__pycache__/*
%{python3_sitelib}/*info/
%{python3_sitelib}/*.py
%files help
%doc CHANGES.md
%changelog
* Tue Dec 31 2019 Yeqing Peng<pengyeqing@huawei.com> - 4.3.0-3
- Type:enhancement
- ID:NA
- SUG:restart
- DESC:update source code
* Tue Sep 10 2019 openEuler Buildteam <buildteam@openeuler.org> - 4.3.0-2
- Package init
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/markeryang/python-decorator.git
git@gitee.com:markeryang/python-decorator.git
markeryang
python-decorator
python-decorator
master

搜索帮助