1 Star 0 Fork 0

wyt/IncludeOS

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
克隆/下载
default.nix 651 Bytes
一键复制 编辑 原始数据 按行查看 历史
# Nix expression to build IncludeOS.
# See https://nixos.org/nix for info about Nix.
#
# Usage:
#
# $ nix-build ./path/to/this/file.nix
#
# Authors: Bjørn Forsman <bjorn.forsman@gmail.com>
{ nixpkgs ? ./pinned.nix, # Builds cleanly May 9. 2024
overlays ? [
(import ./overlay.nix)
],
pkgs ? import nixpkgs { config = {}; inherit overlays; }
}:
let
inherit (pkgs) pkgsIncludeOS;
in
assert (pkgsIncludeOS.stdenv.buildPlatform.isLinux == false) ->
throw "Currently only Linux builds are supported";
assert (pkgsIncludeOS.stdenv.hostPlatform.isMusl == false) ->
throw "Stdenv should be based on Musl";
pkgsIncludeOS.includeos
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/m_wyt/IncludeOS.git
git@gitee.com:m_wyt/IncludeOS.git
m_wyt
IncludeOS
IncludeOS
master

搜索帮助