1 Star 0 Fork 17

lixiaoyong1/python-watchdog

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-watchdog.spec 2.88 KB
一键复制 编辑 原始数据 按行查看 历史
lixiaoyong1 提交于 2024-08-14 07:25 . Update package to version 4.0.2
%global _empty_manifest_terminate_build 0
Name: python-watchdog
Version: 4.0.2
Release: 1
Summary: Filesystem events monitoring
License: Apache-2.0
URL: https://github.com/gorakhargosh/watchdog
Source0: https://files.pythonhosted.org/packages/4f/38/764baaa25eb5e35c9a043d4c4588f9836edfe52a708950f4b6d5f714fd42/watchdog-4.0.2.tar.gz
Requires: python3-PyYAML
%description
Python API and shell utilities to monitor file system events.
Works on 3.6+.
%package -n python3-watchdog
Summary: Filesystem events monitoring
Provides: python-watchdog
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-cffi
BuildRequires: gcc
%description -n python3-watchdog
Python API and shell utilities to monitor file system events.
Works on 3.6+.
%package help
Summary: Development documents and examples for watchdog
Provides: python3-watchdog-doc
%description help
Python API and shell utilities to monitor file system events.
Works on 3.6+.
%prep
%autosetup -n watchdog-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-watchdog -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Aug 14 2024 lixiaoyong <lixiaoyong@kylinos.cn> - 4.0.2-1
- Update package to version 4.0.2
- Add support for Python 3.13
- Remove execution rights from events.py
- Fix missing event_filter for the full emitter
* Tue Jul 30 2024 muxiaohui <muxiaohui@kylinos.cn> - 4.0.0-1
- Update package to version 4.0.0
- Add typing to dirsnapshot.
- Added DirectorySnapshotDiff.ContextManager.
* Mon Apr 10 2023 liyanan <thistleslyn@163.com> - 3.0.0-1
- Upgrade package to version 3.0.0
* Wed Feb 8 2023 wubijie <wubijie@kylinos.cn> - 2.2.1-1
- Update package to version 2.2.1
* Mon Dec 12 2022 Wenzhiwei <wenzhiwei@kylinos.cn> - 2.2.0-1
- Upgrade to 2.2.0
* Tue Sep 27 2022 jiangxinyu <jiangxinyu@kylinos.cn> - 2.1.9-1
- Upgrade to 2.1.9
* Fri May 20 2022 liukuo <liukuo@kylinos.cn> - 2.1.3-2
- License compliance rectification
* Thu Jul 22 2021 Python_Bot <Python_Bot@openeuler.org> - 2.1.3-1
- Package Spec generated
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/lixiaoyong1/python-watchdog.git
git@gitee.com:lixiaoyong1/python-watchdog.git
lixiaoyong1
python-watchdog
python-watchdog
master

搜索帮助