1 Star 0 Fork 11

lixiaoyong1/python-peewee

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-peewee.spec 3.97 KB
一键复制 编辑 原始数据 按行查看 历史
lixiaoyong1 提交于 2024-10-22 02:02 . Upgrade to version 3.17.7
%global _empty_manifest_terminate_build 0
Name: python-peewee
Version: 3.17.7
Release: 1
Summary: a little orm
License: MIT
URL: https://github.com/coleifer/peewee/
Source0: https://files.pythonhosted.org/packages/e1/2d/c5e34703c118da6dae4de89d5c9b5a2fb9fbc2f7789ac2c8d8836f6367ba/peewee-3.17.7.tar.gz
BuildArch: noarch
%description
Peewee is a simple and small ORM. It has few (but expressive) concepts, making it easy to learn and intuitive to use.
%package -n python3-peewee
Summary: a little orm
Provides: python-peewee = %{version}-%{release}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-peewee
Peewee is a simple and small ORM. It has few (but expressive) concepts, making it easy to learn and intuitive to use.
%package help
Summary: Development documents and examples for peewee
Provides: python3-peewee-doc
%description help
Peewee is a simple and small ORM. It has few (but expressive) concepts, making it easy to learn and intuitive to use.
%prep
%autosetup -n peewee-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
if [ -f README.rst ]; then cp -af README.rst %{buildroot}/%{_pkgdocdir}; fi
if [ -f README.md ]; then cp -af README.md %{buildroot}/%{_pkgdocdir}; fi
if [ -f README.txt ]; then cp -af README.txt %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-peewee -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Oct 22 2024 lixiaoyong <lixiaoyong@kylinos.cn> - 3.17.7-1
- Upgrade to version 3.17.7
- Add db_url support for psycopg3 via psycopg3://.
- Ensure double-quotes are escaped properly when introspecting constraints.
- A few documentation-related fixes.
* Sat Aug 03 2024 muxiaohui <muxiaohui@kylinos.cn> - 3.17.6-1
- Update package to version 3.17.6
- Fix bug in recursive model.delete_instance() when a table contains foreign-keys at multiple depths of the graph
- Fix regression that broke server-side cursors with Postgres
- Fix quoting issue in pwiz that could generate invalid python code for double-quoted string literals used as column defaults.
* Mon Jun 17 2024 liyue01 <liyue01@kylinos.cn> - 3.17.5-1
- Update package to version 3.17.5
- Full support for psycopg3,Basic support for Sqlite jsonb;
- Fix bug that could occur when using CASE inside a function, and one or more of the CASE clauses consisted of a subquery;
- Fix bug in the conversion of TIMESTAMP type in Sqlite on Python 3.12+;
- Fix for hybrid properties on subclasses when aliased;
* Tue Mar 26 2024 zhaojingyu <zhaojingyu@kylinos.cn> - 3.17.1-1
- Update package to version 3.17.1
* Mon May 08 2023 wubijie <wubijie@kylinos.cn> - 3.16.2-1
- Update package to version 3.16.2
* Sat May 06 2023 wubijie <wubijie@kylinos.cn> - 3.16.1-1
- Update package to version 3.16.1
* Fri Mar 17 2023 wubijie <wubijie@kylinos.cn> - 3.16.0-1
- Update package to version 3.16.0
* Tue Feb 07 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 3.15.4-1
- Update package to version 3.15.4
* Mon Nov 14 2022 lvfei <lvfei@kylinos.cn> - 3.15.3-1
- Update to 3.15.3
* Fri Aug 05 2022 liukuo <liukuo@kylinos.cn> - 3.15.1-1
- Update to 3.15.1
* Thu Dec 16 2021 Python_Bot <Python_Bot@openeuler.org> - 3.14.8-1
- Package Init
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/lixiaoyong1/python-peewee.git
git@gitee.com:lixiaoyong1/python-peewee.git
lixiaoyong1
python-peewee
python-peewee
master

搜索帮助