1 Star 0 Fork 8

李璐/python-pep8-naming

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-pep8-naming.spec 2.70 KB
一键复制 编辑 原始数据 按行查看 历史
李璐 提交于 2024-08-10 18:55 . Update package to version 0.14.1
%global _empty_manifest_terminate_build 0
Name: python-pep8-naming
Version: 0.14.1
Release: 1
Summary: Check PEP-8 naming conventions, plugin for flake8
License: Expat license
URL: https://github.com/PyCQA/pep8-naming
Source0: https://files.pythonhosted.org/packages/be/8e/1de32e908d8b008bb9352bfe7749aedecb71e2793d36c7ee342716acd1ec/pep8-naming-0.14.1.tar.gz
BuildArch: noarch
Requires: python3-flake8
%description
Check your code against PEP 8 naming conventions.
This module provides a plugin for flake, the Python code checker.
(It replaces the plugin flint-naming for the flint checker.)
%package -n python3-pep8-naming
Summary: Check PEP-8 naming conventions, plugin for flake8
Provides: python-pep8-naming
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-pep8-naming
Check your code against PEP 8 naming conventions.
This module provides a plugin for flake, the Python code checker.
(It replaces the plugin flint-naming for the flint checker.)
%package help
Summary: Development documents and examples for pep8-naming
Provides: python3-pep8-naming-doc
%description help
Check your code against PEP 8 naming conventions.
This module provides a plugin for flake, the Python code checker.
(It replaces the plugin flint-naming for the flint checker.)
%prep
%autosetup -n pep8-naming-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pep8-naming -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sat Aug 10 2024 lilu <lilu@kylinos.cn> - 0.14.1-1
- Update package to version 0.14.1
- Require Python 3.8 or later
* Wed Jul 05 2023 chenzixuan <chenzixuan@kylinos.cn> - 0.13.3-1
- Update package to version 0.13.3
* Sat Sep 24 2022 guozhengxin <guozhengxin@kylinos.cn> - 0.13.2-1
- Upgrade package to version 0.13.2
* Mon Oct 12 2020 maminjie <maminjie1@huawei.com> - 0.11.1-1
- Package Init
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/lilu_ll/python-pep8-naming.git
git@gitee.com:lilu_ll/python-pep8-naming.git
lilu_ll
python-pep8-naming
python-pep8-naming
master

搜索帮助