1 Star 0 Fork 38

雷炬/python-urllib3

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-urllib3.spec 2.53 KB
一键复制 编辑 原始数据 按行查看 历史
%global srcname urllib3
%bcond_without tests
Name: python-%{srcname}
Version: 1.25.9
Release: 1
Summary: Sanity-friendly HTTP client for Python
License: MIT
URL: https://urllib3.readthedocs.io
Source0: https://github.com/urllib3/urllib3/archive/%{version}/%{version}.tar.gz
Source1: ssl_match_hostname_py3.py
BuildArch: noarch
%description
HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more.
%package -n python3-%{srcname}
Summary: Python3 HTTP library with thread-safe connection pooling and file post
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%if %{with tests}
BuildRequires: python3-nose python3-mock python3-six python-idna
BuildRequires: python3-pysocks python3-pytest python3-tornado python-trustme
%endif
Requires: ca-certificates python3-idna python3-six python3-pysocks
%description -n python3-urllib3
Python3 HTTP module with connection pooling and file POST abilities.
%prep
%autosetup -n %{srcname}-%{version} -p1
#Failure use case circumvention
rm -rf test/with_dummyserver/
rm -rf test/appengine/
rm -rf test/contrib/
rm -rf test/test_no_ssl.py
%build
%py3_build
%install
%py3_install
rm -rf %{buildroot}%{python3_sitelib}/urllib3/packages/six.py*
rm -rf %{buildroot}%{python3_sitelib}/urllib3/packages/__pycache__/six*
rm -rf %{buildroot}%{python3_sitelib}/urllib3/packages/ssl_match_hostname/
mkdir -p %{buildroot}/%{python3_sitelib}/urllib3/packages/
cp -a %{SOURCE1} %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname.py
ln -s %{python3_sitelib}/six.py %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py
ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.opt-1.pyc %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.pyc %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
%if %{with tests}
%check
PYTHONPATH=%{buildroot}%{python3_sitelib}:%{python3_sitelib} %{__python3} -m pytest -v
%endif
%files -n python3-urllib3
%defattr(-,root,root)
%license LICENSE.txt
%doc CHANGES.rst README.rst CONTRIBUTORS.txt
%{python3_sitelib}/urllib3/
%{python3_sitelib}/urllib3-*.egg-info
%changelog
* Tue Jul 28 2020 chengguipeng<chengguipeng@huawei.com> - 1.25.9-1
- upgrade to 1.25.9
* Sat Oct 26 2019 openEuler Buildteam <buildteam@openeuler.org> - 1.24.3-2
- optimize spec file.
* Mon Sep 16 2019 openEuler Buildteam <buildteam@openeuler.org> - 1.24.3-1
- Package init
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/lei_ju/python-urllib3.git
git@gitee.com:lei_ju/python-urllib3.git
lei_ju
python-urllib3
python-urllib3
master

搜索帮助