1 Star 0 Fork 3

xiehongyu/python-stomper

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-stomper.spec 2.51 KB
一键复制 编辑 原始数据 按行查看 历史
xiehongyu 提交于 2021-07-09 18:19 . 添加python-stomper-0.4.3-1
%{?python_enable_dependency_generator}
# Disable Python 2
%bcond_with python2
# Enable Python 3
%bcond_without python3
%global commit 9b9fddf596a77e6b7e0407f0e45d02ca3a5ba5e1
%global shortcommit %(c=%{commit}; echo ${c:0:7})
Name: python-stomper
Version: 0.4.3
Release: 1
Summary: A python client implementation of the STOMP protocol
License: ASL 2.0
URL: https://pypi.io/project/stomper
Source0: https://pypi.io/packages/source/s/stomper/stomper-%{version}.tar.gz
BuildArch: noarch
%description
This is a python client implementation of the STOMP protocol. The client is
attempting to be transport layer neutral. This module provides functions to
create and parse STOMP messages in a programatic fashion.
%if %{with python2}
%package -n python2-stomper
Summary: A python client implementation of the STOMP protocol
%{?python_provide:%python_provide python2-stomper}
BuildRequires: python2-devel
BuildRequires: python2-setuptools
BuildRequires: python2-nose
BuildRequires: python2-future
%if %{undefined __pythondist_requires}
Requires: python2-future
%endif
%description -n python2-stomper
This is a python client implementation of the STOMP protocol. The client is
attempting to be transport layer neutral. This module provides functions to
create and parse STOMP messages in a programatic fashion.
%endif
%if %{with python3}
%package -n python3-stomper
Summary: A python client implementation of the STOMP protocol
%{?python_provide:%python_provide python3-stomper}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-nose
%description -n python3-stomper
This is a python client implementation of the STOMP protocol. The client is
attempting to be transport layer neutral. This module provides functions to
create and parse STOMP messages in a programatic fashion.
%endif
%prep
%setup -q -n stomper-%{version}
%build
%if %{with python2}
%{py2_build}
%endif
%if %{with python3}
%{py3_build}
%endif
%install
%if %{with python2}
%{py2_install}
%endif
%if %{with python3}
%{py3_install}
%endif
%check
%if %{with python2}
PYTHONPATH=. nosetests-%{python2_version} -q
%endif
%if %{with python3}
PYTHONPATH=. nosetests-%{python3_version} -q
%endif
%if %{with python2}
%files -n python2-stomper
%doc README.rst
%{python2_sitelib}/stomper*
%endif
%if %{with python3}
%files -n python3-stomper
%doc README.rst
%{python3_sitelib}/stomper*
%endif
%changelog
* Fri Jul 09 2021 xiehongyu <xiehongyu@kylinos.cn> - 0.4.3-1
- Initial package
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/kylinxhy/python-stomper.git
git@gitee.com:kylinxhy/python-stomper.git
kylinxhy
python-stomper
python-stomper
master

搜索帮助