1 Star 0 Fork 11

nyr/python-munch

forked from src-openEuler/python-munch 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-munch.spec 3.77 KB
一键复制 编辑 原始数据 按行查看 历史
nyr 提交于 2023-07-25 22:38 . updated to latest:4.0.0
%global _empty_manifest_terminate_build 0
Name: python-munch
Version: 4.0.0
Release: 1
Summary: A dot-accessible dictionary (a la JavaScript objects)
License: MIT
URL: https://github.com/Infinidat/munch
Source0: https://files.pythonhosted.org/packages/e7/2b/45098135b5f9f13221820d90f9e0516e11a2a0f55012c13b081d202b782a/munch-4.0.0.tar.gz
BuildArch: noarch
Requires: python3-six
Requires: python3-pytest
Requires: python3-coverage
Requires: python3-astroid
Requires: python3-pylint
Requires: python3-astroid
Requires: python3-pylint
Requires: python3-PyYAML
%description
munch is a fork of David Schoonover's **Bunch** package, providing similar functionality. 99% of the work was done by him, and the fork was made mainly for lack of responsiveness for fixes and maintenance on the original code.
Munch is a dictionary that supports attribute-style access, a la JavaScript:
```python
>>> b = Munch()
>>> b.hello = 'world'
>>> b.hello
'world'
>>> b['hello'] += "!"
>>> b.hello
'world!'
>>> b.foo = Munch(lol=True)
>>> b.foo.lol
True
>>> b.foo is b['foo']
True
```
%package -n python3-munch
Summary: A dot-accessible dictionary (a la JavaScript objects)
Provides: python-munch = %{version}-%{release}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pbr
%description -n python3-munch
munch is a fork of David Schoonover's **Bunch** package, providing similar functionality. 99% of the work was done by him, and the fork was made mainly for lack of responsiveness for fixes and maintenance on the original code.
Munch is a dictionary that supports attribute-style access, a la JavaScript:
```python
>>> b = Munch()
>>> b.hello = 'world'
>>> b.hello
'world'
>>> b['hello'] += "!"
>>> b.hello
'world!'
>>> b.foo = Munch(lol=True)
>>> b.foo.lol
True
>>> b.foo is b['foo']
True
```
%package help
Summary: Development documents and examples for munch
Provides: python3-munch-doc
%description help
munch is a fork of David Schoonover's **Bunch** package, providing similar functionality. 99% of the work was done by him, and the fork was made mainly for lack of responsiveness for fixes and maintenance on the original code.
Munch is a dictionary that supports attribute-style access, a la JavaScript:
```python
>>> b = Munch()
>>> b.hello = 'world'
>>> b.hello
'world'
>>> b['hello'] += "!"
>>> b.hello
'world!'
>>> b.foo = Munch(lol=True)
>>> b.foo.lol
True
>>> b.foo is b['foo']
True
```
%prep
%autosetup -n munch-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-munch -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jul 25 2023 niuyaru <niuyaru@kylinos.cn> - 4.0.0-1
- Update package to version 4.0.0
* Tue May 16 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 3.0.0-1
- Update package to version 3.0.0
* Mon Jan 06 2020 lingsheng <lingsheng@huawei.com> - 2.5.0-2
- Add buildrequire python3-pbr
* Mon Oct 19 2020 Python_Bot <Python_Bot@openeuler.org> - 2.5.0-1
- Package Spec generated
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/kirin_2_0/python-munch.git
git@gitee.com:kirin_2_0/python-munch.git
kirin_2_0
python-munch
python-munch
master

搜索帮助