1 Star 0 Fork 9

nyr/python-identify

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-identify.spec 3.01 KB
一键复制 编辑 原始数据 按行查看 历史
nyr 提交于 2023-08-01 11:04 . updated to latest:2.5.26
%global _empty_manifest_terminate_build 0
Name: python-identify
Version: 2.5.26
Release: 1
Summary: File identification library for Python
License: MIT
URL: https://github.com/pre-commit/identify
Source0: https://files.pythonhosted.org/packages/93/1f/19d02def7b525871585516278838510b8ae618723e47500eff9fc67363ff/identify-2.5.26.tar.gz
BuildArch: noarch
%description
File identification library for Python.
Given a file (or some information about a file), return a set of standardized tags identifying what the file is.
%package -n python3-identify
Summary: File identification library for Python
Provides: python-identify = %{version}-%{release}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-wheel
%description -n python3-identify
File identification library for Python.
Given a file (or some information about a file), return a set of standardized tags identifying what the file is.
%package help
Summary: Development documents and examples for identify
Provides: python3-identify-doc
%description help
File identification library for Python.
Given a file (or some information about a file), return a set of standardized tags identifying what the file is.
%prep
%autosetup -n identify-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-identify -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Aug 01 2023 niuyaru <niuyaru@kylinos.cn> - 2.5.26-1
- Update package to version 2.5.26
* Wed Jun 21 2023 chendexi <chendexi@kylinos.cn> - 2.5.24-1
- Update package to version 2.5.24
* Fri Apr 7 2023 liyanan <thistleslyn@163.com> - 2.5.22-1
- Upgrade package to version 2.5.22
* Fri Feb 24 2023 wubijie <wubijie@kylinos.cn> - 2.5.18-1
- Update package to version 2.5.18
* Wed Feb 8 2023 wubijie <wubijie@kylinos.cn> - 2.5.17-1
- Update package to version 2.5.17
* Fri Dec 16 2022 jiangxinyu <jiangxinyu@kylinos.cn> - 2.5.10-1
- Update package to version 2.5.10
* Thu Nov 03 2022 wangjunqi <wangjunqi@kylinos.cn> - 2.5.8-1
- Update package to version 2.5.8
* Tue Jul 13 2021 OpenStack_SIG <openstack@openeuler.org> - 2.2.10-1
- Package Spec generate
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/kirin_2_0/python-identify.git
git@gitee.com:kirin_2_0/python-identify.git
kirin_2_0
python-identify
python-identify
master

搜索帮助

D67c1975 1850385 1daf7b77 1850385