1 Star 0 Fork 0

kenneway/substrate

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
克隆/下载
shell.nix 826 Bytes
一键复制 编辑 原始数据 按行查看 历史
let
mozillaOverlay =
import (builtins.fetchGit {
url = "https://github.com/mozilla/nixpkgs-mozilla.git";
rev = "4a07484cf0e49047f82d83fd119acffbad3b235f";
});
nixpkgs = import <nixpkgs> { overlays = [ mozillaOverlay ]; };
rust-nightly = with nixpkgs; ((rustChannelOf { date = "2021-09-10"; channel = "nightly"; }).rust.override {
extensions = [ "rust-src" ];
targets = [ "wasm32-unknown-unknown" ];
});
in
with nixpkgs; pkgs.mkShell {
buildInputs = [
clang
openssl.dev
pkg-config
rust-nightly
] ++ lib.optionals stdenv.isDarwin [
darwin.apple_sdk.frameworks.Security
];
RUST_SRC_PATH = "${rust-nightly}/lib/rustlib/src/rust/src";
LIBCLANG_PATH = "${llvmPackages.libclang.lib}/lib";
PROTOC = "${protobuf}/bin/protoc";
ROCKSDB_LIB_DIR = "${rocksdb}/lib";
}
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/kenneway/substrate.git
git@gitee.com:kenneway/substrate.git
kenneway
substrate
substrate
master

搜索帮助