1 Star 0 Fork 12

yuqi/python-smmap

forked from src-openEuler/python-smmap 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-smmap.spec 2.64 KB
一键复制 编辑 原始数据 按行查看 历史
yuqi 提交于 2022-06-04 05:34 . upgrade the version of smmap to 5.0.0
%global _empty_manifest_terminate_build 0
Name: python-smmap
Version: 5.0.0
Release: 1
Summary: A pure Python implementation of a sliding window memory map manager
License: BSD
URL: https://github.com/gitpython-developers/smmap
Source0: https://files.pythonhosted.org/packages/21/2d/39c6c57032f786f1965022563eec60623bb3e1409ade6ad834ff703724f3/smmap-5.0.0.tar.gz
BuildArch: noarch
%description
A pure Python implementation of a sliding window memory map manager
%package -n python3-smmap
Summary: A pure Python implementation of a sliding window memory map manager
Provides: python-smmap
# Base build requires
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-wheel
BuildRequires: python3-pytest
%description -n python3-smmap
A pure Python implementation of a sliding window memory map manager
%package help
Summary: A pure Python implementation of a sliding window memory map manager
Provides: python3-smmap-doc
%description help
A pure Python implementation of a sliding window memory map manager
%prep
%autosetup -n smmap-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%check
pytest
%files -n python3-smmap -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sat Jun 04 2022 OpenStack_SIG <openstack@openeuler.org> - 5.0.0-1
- Upgrade package python3-smmap to version 5.0.0
* Fri May 13 2022 xu_ping <xuping33@h-partners.com> - 3.0.5-2
- Remove test dependencies on python-nosexcover during the build process
* Fri Aug 06 2021 OpenStack_SIG <openstack@openeuler.org> - 3.0.5-1
- Upgrade version to 3.0.5
* Fri Sep 04 2020 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/huyuqi2/python-smmap.git
git@gitee.com:huyuqi2/python-smmap.git
huyuqi2
python-smmap
python-smmap
master

搜索帮助