1 Star 0 Fork 16

huangtianhua/python-pint

forked from src-openEuler/python-pint 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-pint.spec 4.25 KB
一键复制 编辑 原始数据 按行查看 历史
王玺源 提交于 2021-08-06 04:07 . Drop non-exist extra Requires
%global _empty_manifest_terminate_build 0
Name: python-pint
Version: 0.16.1
Release: 3
Summary: Physical quantities module
License: BSD
URL: https://github.com/hgrecco/pint
Source0: https://files.pythonhosted.org/packages/2b/d4/18becb51e9e242640010362b38dde187ecc0d5caeb0a689a2a60083b1ca3/Pint-0.16.1.tar.gz
BuildArch: noarch
%description
Pint is a Python package to define, operate and manipulate physical
quantities: the product of a numerical value and a unit of measurement.
It allows arithmetic operations between them and conversions from and
to different units.
It is distributed with a comprehensive list of physical units, prefixes
and constants. Due to its modular design, you can extend (or even rewrite!)
the complete list without changing the source code. It supports a lot of
numpy mathematical operations **without monkey patching or wrapping numpy**.
It has a complete test coverage. It runs in Python 3.6+ with no other dependency.
If you need Python 2.7 or 3.4/3.5 compatibility, use Pint 0.9.
It is licensed under BSD.
%package -n python3-pint
Summary: Physical quantities module
Provides: python-pint
BuildRequires: python3-devel
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-setuptools
BuildRequires: python3-setuptools_scm
Requires: python3-packaging
Requires: python3-importlib-resources
Requires: python3-importlib-metadata
Requires: python3-numpy
Requires: python3-pytest
Requires: python3-pytest-cov
%description -n python3-pint
Pint is a Python package to define, operate and manipulate physical
quantities: the product of a numerical value and a unit of measurement.
It allows arithmetic operations between them and conversions from and
to different units.
It is distributed with a comprehensive list of physical units, prefixes
and constants. Due to its modular design, you can extend (or even rewrite!)
the complete list without changing the source code. It supports a lot of
numpy mathematical operations **without monkey patching or wrapping numpy**.
It has a complete test coverage. It runs in Python 3.6+ with no other dependency.
If you need Python 2.7 or 3.4/3.5 compatibility, use Pint 0.9.
It is licensed under BSD.
%package help
Summary: Development documents and examples for Pint
Provides: python3-pint-doc
%description help
Pint is a Python package to define, operate and manipulate physical
quantities: the product of a numerical value and a unit of measurement.
It allows arithmetic operations between them and conversions from and
to different units.
It is distributed with a comprehensive list of physical units, prefixes
and constants. Due to its modular design, you can extend (or even rewrite!)
the complete list without changing the source code. It supports a lot of
numpy mathematical operations **without monkey patching or wrapping numpy**.
It has a complete test coverage. It runs in Python 3.6+ with no other dependency.
If you need Python 2.7 or 3.4/3.5 compatibility, use Pint 0.9.
It is licensed under BSD.
%prep
%autosetup -n Pint-0.16.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pint -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Aug 06 2021 wangxiyuan <wangxiyuan1007@gmail.com> - 0.16.1-3
- Drop non-exist extra Requires
* Tue Aug 3 2021 huangtianhua <huangtianhua@huawei.com> - 0.16.1-2
- Adds python3-setuptools_scm as BuildRequires
* Wed Nov 25 2020 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/huangtianhua/python-pint.git
git@gitee.com:huangtianhua/python-pint.git
huangtianhua
python-pint
python-pint
master

搜索帮助