1 Star 0 Fork 24

韩光宇/python-eventlet

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-eventlet.spec 2.95 KB
一键复制 编辑 原始数据 按行查看 历史
xu_ping 提交于 2023-05-08 11:18 . Upgrade to 0.33.3
%global _empty_manifest_terminate_build 0
Name: python-eventlet
Version: 0.33.3
Release: 1
Summary: Highly concurrent networking library
License: MIT
URL: http://eventlet.net
Source0: https://files.pythonhosted.org/packages/source/e/eventlet/eventlet-%{version}.tar.gz
BuildArch: noarch
%description
Eventlet is a concurrent networking library for Python that allows you to change how you run your code, not how you write it.
%package -n python3-eventlet
Summary: Highly concurrent networking library
Provides: python-eventlet
# Base build requires
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-wheel
# General requires
BuildRequires: python3-dns
BuildRequires: python3-greenlet
BuildRequires: python3-six
# General requires
Requires: python3-dns
Requires: python3-greenlet
Requires: python3-six
%description -n python3-eventlet
Eventlet is a concurrent networking library for Python that allows you to change how you run your code, not how you write it.
%package help
Summary: Highly concurrent networking library
Provides: python3-eventlet-doc
%description help
Eventlet is a concurrent networking library for Python that allows you to change how you run your code, not how you write it.
%prep
%autosetup -n eventlet-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-eventlet -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sat May 06 2023 xu_ping <707078654@qq.com> - 0.33.3-1
- Update to 0.33.3
* Wed Aug 03 2022 liukuo <liukuo@kylinos.cn> - 0.33.1-1
- Update to 0.33.1
* Wed May 18 2022 OpenStack_SIG <openstack@openeuler.org> - 0.33.0-1
- Upgrade package python3-eventlet to version 0.33.0
* Mon Jul 26 2021 OpenStack_SIG <openstack@openeuler.org> - 0.30.2-1
- update to 0.30.2
* Fri Jan 15 2021 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated
* Thu Mar 12 2020 zoushuangshuang <zoushuangshuang@huawei.com> - 0.23.0-3
- Package init
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/han-guangyu/python-eventlet.git
git@gitee.com:han-guangyu/python-eventlet.git
han-guangyu
python-eventlet
python-eventlet
master

搜索帮助