1 Star 0 Fork 4

davidhan008/mavros

forked from src-openEuler/mavros 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
mavros.spec 5.34 KB
一键复制 编辑 原始数据 按行查看 历史
davidhan008 提交于 2024-01-10 20:15 . init mavros noetic
%bcond_without tests
%bcond_without weak_deps
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
%define RosPkgName mavros
%define with_tests 0
Name: ros-%{ros_distro}-%{RosPkgName}
Version: 1.15.0
Release: 1%{?dist}%{?release_suffix}
Summary: ROS mavros package
Url: http://wiki.ros.org/mavros
License: GPLv3 and LGPLv3 and BSD
Source0: %{name}_%{version}.orig.tar.gz
Requires: boost-devel
Requires: ros-%{ros_distro}-diagnostic-updater
Requires: ros-%{ros_distro}-eigen-conversions
Requires: ros-%{ros_distro}-libmavconn
Requires: ros-%{ros_distro}-pluginlib
Requires: ros-%{ros_distro}-rosconsole-bridge
Requires: ros-%{ros_distro}-roscpp
Requires: ros-%{ros_distro}-tf2-ros
Requires: ros-%{ros_distro}-tf2-eigen
Requires: ros-%{ros_distro}-diagnostic-msgs
Requires: ros-%{ros_distro}-geometry-msgs
Requires: ros-%{ros_distro}-mavros-msgs
Requires: ros-%{ros_distro}-nav-msgs
Requires: ros-%{ros_distro}-sensor-msgs
Requires: ros-%{ros_distro}-geographic-msgs
Requires: ros-%{ros_distro}-trajectory-msgs
Requires: ros-%{ros_distro}-std-msgs
Requires: ros-%{ros_distro}-std-srvs
Requires: ros-%{ros_distro}-mavlink
Requires: geographiclib
Requires: geographiclib-tools
Requires: ros-%{ros_distro}-message-runtime
Requires: ros-%{ros_distro}-rospy
BuildRequires: boost-devel
BuildRequires: ros-%{ros_distro}-diagnostic-updater
BuildRequires: ros-%{ros_distro}-eigen-conversions
BuildRequires: ros-%{ros_distro}-libmavconn
BuildRequires: ros-%{ros_distro}-pluginlib
BuildRequires: ros-%{ros_distro}-rosconsole-bridge
BuildRequires: ros-%{ros_distro}-roscpp
BuildRequires: ros-%{ros_distro}-tf2-ros
BuildRequires: ros-%{ros_distro}-tf2-eigen
BuildRequires: ros-%{ros_distro}-diagnostic-msgs
BuildRequires: ros-%{ros_distro}-geometry-msgs
BuildRequires: ros-%{ros_distro}-mavros-msgs
BuildRequires: ros-%{ros_distro}-nav-msgs
BuildRequires: ros-%{ros_distro}-sensor-msgs
BuildRequires: ros-%{ros_distro}-geographic-msgs
BuildRequires: ros-%{ros_distro}-trajectory-msgs
BuildRequires: ros-%{ros_distro}-std-msgs
BuildRequires: ros-%{ros_distro}-std-srvs
BuildRequires: ros-%{ros_distro}-mavlink
BuildRequires: geographiclib
BuildRequires: geographiclib-tools
BuildRequires: ros-%{ros_distro}-angles
BuildRequires: ros-%{ros_distro}-cmake-modules
BuildRequires: ros-%{ros_distro}-catkin
%if 0%{?with_tests}
BuildRequires: ros-%{ros_distro}-rosunit
BuildRequires: gtest-devel
%endif
Provides: %{name}-devel = %{version}-%{release}
Provides: %{name}-doc = %{version}-%{release}
Provides: %{name}-runtime = %{version}-%{release}
%description
MAVROS -- MAVLink extendable communication node for ROS
with proxy for Ground Control Station.
%prep
%autosetup -p1
%build
# Needed to bootstrap since the ros_workspace package does not yet exist.
export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
export ROS_DISTRO=%{ros_distro}
export ROS_PYTHON_VERSION=%{python3_version}
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree and source it. It will set things like
# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
mkdir -p .obj-%{_target_platform} && cd .obj-%{_target_platform}
%cmake3 \
-UINCLUDE_INSTALL_DIR \
-ULIB_INSTALL_DIR \
-USYSCONF_INSTALL_DIR \
-USHARE_INSTALL_PREFIX \
-ULIB_SUFFIX \
-DCMAKE_INSTALL_PREFIX="/opt/ros/%{ros_distro}" \
-DAMENT_PREFIX_PATH="/opt/ros/%{ros_distro}" \
-DCMAKE_PREFIX_PATH="/opt/ros/%{ros_distro}" \
-DCMAKE_INSTALL_LIBDIR="/opt/ros/%{ros_distro}/lib" \
-DSETUPTOOLS_DEB_LAYOUT=OFF \
%if !0%{?with_tests}
-DBUILD_TESTING=OFF \
%endif
..
%make_build
%install
# Needed to bootstrap since the ros_workspace package does not yet exist.
export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree and source it. It will set things like
# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
%make_install -C .obj-%{_target_platform}
%if 0%{?with_tests}
%check
# Needed to bootstrap since the ros_workspace package does not yet exist.
export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
# Look for a Makefile target with a name indicating that it runs tests
TEST_TARGET=$(%__make -qp -C .obj-%{_target_platform} | sed "s/^\(test\|check\):.*/\\1/;t f;d;:f;q0")
if [ -n "$TEST_TARGET" ]; then
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree and source it. It will set things like
# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
CTEST_OUTPUT_ON_FAILURE=1 \
%make_build -C .obj-%{_target_platform} $TEST_TARGET || echo "RPM TESTS FAILED"
else echo "RPM TESTS SKIPPED"; fi
%endif
%files
/opt/ros/%{ros_distro}
%changelog
* 三 1月 10 2024 Vladimir Ermakov vooon341@gmail.com - 1.15.0-1
- Autogenerated by ros-porting-tools
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/davidhan008/mavros.git
git@gitee.com:davidhan008/mavros.git
davidhan008
mavros
mavros
master

搜索帮助

0d507c66 1850385 C8b1a773 1850385