1 Star 0 Fork 19

compile_success/python-coverage

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-coverage.spec 2.60 KB
一键复制 编辑 原始数据 按行查看 历史
orange-snn 提交于 2021-01-30 18:06 . init
Name: python-coverage
Version: 5.3.1
Release: 1
Summary: Code coverage measurement for Python
License: ASL 2.0 and MIT and (MIT or GPL)
URL: https://coverage.readthedocs.io/en/coverage-%{version}/
Source0: https://github.com/nedbat/coveragepy/archive/coverage-%{version}.tar.gz
BuildRequires: gcc
%description
Coverage.py is a tool for measuring code coverage of Python programs. It monitors
your program, noting which parts of the code have been executed, then analyzes the
source to identify code that could have been executed but was not.
Coverage measurement is typically used to gauge the effectiveness of tests. It can
show which parts of your code are being exercised by tests, and which are not.
%package -n python3-coverage
Summary: Code coverage measurement for Python 3
BuildRequires: python3-devel python3-setuptools
Requires: python3-setuptools
%{?python_provide:%python_provide python3-coverage}
Provides: bundled(js-jquery) = 1.11.1 bundled(js-jquery-debounce) = 1.1
Provides: bundled(js-jquery-hotkeys) = 0.8 bundled(js-jquery-tablesorter)
Provides: bundled(js-jquery-isonscreen) = 1.2.0
Obsoletes: platform-python-coverage < %{version}-%{release}
%description -n python3-coverage
Coverage.py is a tool for measuring code coverage of Python 3 programs. It monitors
your program, noting which parts of the code have been executed, then analyzes the
source to identify code that could have been executed but was not.
%prep
%autosetup -n coveragepy-coverage-%{version} -p1
sed -i 's/\r//g' README.rst
find . -type f ! -perm 0644 -exec chmod 0644 \{\} \;
%build
%py3_build
%install
%py3_install
mv %{buildroot}/%{_bindir}/coverage %{buildroot}/%{_bindir}/python3-coverage
find %{buildroot}/%{_bindir} -type f -name "coverage*" -delete
pushd %{buildroot}%{_bindir}
ln -s python3-coverage coverage3
ln -s python3-coverage coverage-%{python3_version}
popd
%files -n python3-coverage
%doc README.rst
%license NOTICE.txt LICENSE.txt
%{_bindir}/coverage-%{python3_version}
%{_bindir}/coverage3
%{_bindir}/python3-coverage
%{python3_sitearch}/coverage/
%{python3_sitearch}/coverage-%{version}-py?.?.egg-info/
%changelog
* Sat Jan 30 2021 zhujunhao <zhujunhao8@huawei.com> - 5.3.1-1
- DESC:update to 5.3.1
* Thu Oct 29 2020 gaihuiying <gaihuiying1@huawei.com> - 5.2-2
- Type:requirement
- ID:NA
- SUG:NA
- DESC:remove python2
* Tue Jul 28 2020 liulong <liulong20@huawei.com> - 5.2-1
- Type:requirement
- ID:NA
- SUG:NA
- DESC:update coverage version to 5.2
* Sat Oct 12 2019 openEuler Buildteam <buildteam@openeuler.org> - 4.5.3-1
- Package Init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/compile_success/python-coverage.git
git@gitee.com:compile_success/python-coverage.git
compile_success
python-coverage
python-coverage
master

搜索帮助