1 Star 0 Fork 0

carlosclb/sgy_plot

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
segy_plot.spec 1.11 KB
一键复制 编辑 原始数据 按行查看 历史
carlosclb 提交于 2024-08-02 04:06 . pyinstallr segy_plot.spec
# -*- mode: python ; coding: utf-8 -*-
import os
import obspy
dirname = os.path.dirname(os.path.dirname(obspy.__file__))
data_list = [(dirname+'\\'+x,x) for x in os.listdir(dirname) if '-info' in x] + [(dirname+'\\'+x,x) for x in os.listdir(dirname) if 'obspy' in x]
####添加上面这几句
a = Analysis(
['C:\\Users\\demo\\PycharmProjects\\plot_sgy\\to_exe\\segy_plot.py'],
pathex=[],
binaries=[],
datas=data_list, #这里需要改动
hiddenimports=[],
hookspath=[],
hooksconfig={},
runtime_hooks=[],
excludes=[],
noarchive=False,
optimize=0,
)
pyz = PYZ(a.pure)
exe = EXE(
pyz,
a.scripts,
[],
exclude_binaries=True,
name='segy_plot',
debug=False,
bootloader_ignore_signals=False,
strip=False,
upx=True,
console=False,
disable_windowed_traceback=False,
argv_emulation=False,
target_arch=None,
codesign_identity=None,
entitlements_file=None,
)
coll = COLLECT(
exe,
a.binaries,
a.datas,
strip=False,
upx=True,
upx_exclude=[],
name='segy_plot',
)
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/carlosclb/sgy_plot.git
git@gitee.com:carlosclb/sgy_plot.git
carlosclb
sgy_plot
sgy_plot
master

搜索帮助