1 Star 0 Fork 7

liliang/python-emcee

forked from src-openEuler/python-emcee 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
emcee.spec 2.70 KB
一键复制 编辑 原始数据 按行查看 历史
liliang 提交于 2021-07-06 10:50 . Init project python-emcee
%global _empty_manifest_terminate_build 0
Name: python-emcee
Version: 3.1.0
Release: 1
Summary: The Python ensemble sampling toolkit for MCMC
License: MIT
URL: https://github.com/dfm/emcee/
Source0: https://github.com/dfm/emcee/archive/v3.1.0/emcee-3.1.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-h5py
Requires: python3-pip3
Requires: python3-scipy
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-coverage[toml]
%description
emcee is a stable, well tested Python implementation of the
affine-invariant ensemble sampler for Markov chain Monte Carlo (MCMC)
proposed by Goodman & Weare (2010). The code is open source and
has already been used in several published projects in the Astrophysics literature.
%package -n python3-emcee
Summary: The Python ensemble sampling toolkit for MCMC
Provides: python-emcee
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-emcee
emcee is a stable, well tested Python implementation of the
affine-invariant ensemble sampler for Markov chain Monte Carlo (MCMC)
proposed by Goodman & Weare (2010). The code is open source and
has already been used in several published projects in the Astrophysics literature.
%package help
Summary: Development documents and examples for emcee
Provides: python3-emcee-doc
%description help
emcee is a stable, well tested Python implementation of the
affine-invariant ensemble sampler for Markov chain Monte Carlo (MCMC)
proposed by Goodman & Weare (2010). The code is open source and
has already been used in several published projects in the Astrophysics literature.
%prep
%autosetup -n emcee-3.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-emcee -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Jul 05 2021 liliang <liliang@kylinos.cn> - 3.1.0-1
- Initial package.
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/LiLiang602/python-emcee.git
git@gitee.com:LiLiang602/python-emcee.git
LiLiang602
python-emcee
python-emcee
master

搜索帮助