代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/python-trio 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%global _empty_manifest_terminate_build 0
Name: python-trio
Version: 0.27.0
Release: 1
Summary: A friendly Python library for async concurrency and I/O
License: Apache-2.0
URL: https://github.com/python-trio/trio
Source0: https://files.pythonhosted.org/packages/17/d1/a83dee5be404da7afe5a71783a33b8907bacb935a6dc8c69ab785e4a3eed/trio-0.27.0.tar.gz
BuildArch: noarch
%description
The Trio project's goal is to produce a production-quality, permissively licensed,
async/await-native I/O library for Python. Like all async libraries,
its main purpose is to help you write programs that do multiple things at the same time
with parallelized I/O. A web spider that wants to fetch lots of pages in parallel,
a web server that needs to juggle lots of downloads and websocket connections
at the same time, a process supervisor monitoring multiple subprocesses...
that sort of thing. Compared to other libraries, Trio attempts to distinguish
itself with an obsessive focus on usability and correctness.
Concurrency is complicated; we try to make it easy to get things right.
%package -n python3-trio
Summary: A friendly Python library for async concurrency and I/O
Provides: python-trio
# Base build requires
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-pip
BuildRequires: python3-wheel
BuildRequires: python3-hatchling
# General requires
BuildRequires: python3-attrs
BuildRequires: python3-sortedcontainers
BuildRequires: python3-idna
BuildRequires: python3-cffi
%description -n python3-trio
The Trio project's goal is to produce a production-quality, permissively licensed,
async/await-native I/O library for Python.
%package help
Summary: A friendly Python library for async concurrency and I/O
Provides: python3-trio-doc
%description help
The Trio project's goal is to produce a production-quality, permissively licensed,
async/await-native I/O library for Python. Like all async libraries,
its main purpose is to help you write programs that do multiple things at the same time
with parallelized I/O. A web spider that wants to fetch lots of pages in parallel,
a web server that needs to juggle lots of downloads and websocket connections
at the same time, a process supervisor monitoring multiple subprocesses...
that sort of thing. Compared to other libraries, Trio attempts to distinguish
itself with an obsessive focus on usability and correctness.
Concurrency is complicated; we try to make it easy to get things right.
%prep
%autosetup -n trio-%{version}
%build
%pyproject_build
%install
%pyproject_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-trio
%license LICENSE LICENSE.APACHE2 LICENSE.MIT
%doc README.rst
%{python3_sitelib}/trio*
%files help
%{_docdir}/*
%changelog
* Thu Oct 24 2024 guochao <guochao@kylinos.cn> - 0.27.0-1
- Upgrade package to 0.27.0
- Fix test.polish comments and tests
- Break lots before other checks, minor phrasing improvement in docstring
* Wed Aug 21 2024 guochao <guochao@kylinos.cn> - 0.26.2-1
- Upgrade package to 0.26.2
- Switch to uv pip compile
- Update to mypy 1.11.0
- Use 3.12 for formatting check
- Fix attrs redone
* Tue Jul 23 2024 warlcok <hunan@kylinos.cn> - 0.26.0-1
- Upgrade package to 0.26.0
- Added an interactive interpreter
Fixed a bug with incorrectly failed matches
* Thu Jun 20 2024 liuzhilin <liuzhilin@kylinos.cn> - 0.25.1-1
- Upgrade package 0.25.1
- Fix crash when importing trio in embedded Python on Windows, and other installs that remove docstrings.
* Tue Aug 22 2023 luolu12 <luluoc@isoftstone.com> - 0.22.2-1
- Upgrade package python3-trio of version 0.22.2
* Fri Jun 30 2023 luolu12 <luluoc@isoftstone.com> - 0.22.0-1
- Upgrade package python3-trio of version 0.22.0
* Thu Jul 21 2022 renliang16 <renliang@uniontech.com> - 0.14.0-1
- Init package python3-trio of version 0.14.0
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。