1 Star 0 Fork 0

adp-neo/cde

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
克隆/下载
flake.nix 673 Bytes
一键复制 编辑 原始数据 按行查看 历史
Jiuyang Liu 提交于 2023-08-05 23:04 . use nix to install dependencies
{
description = "cde";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, flake-utils }@inputs:
let
overlay = import ./overlay.nix;
in
flake-utils.lib.eachDefaultSystem
(system:
let
pkgs = import nixpkgs { inherit system; overlays = [ overlay ]; };
deps = with pkgs; [
git
mill
];
in
{
legacyPackages = pkgs;
devShell = pkgs.mkShell {
buildInputs = deps;
};
}
)
// { inherit inputs; overlays.default = overlay; };
}
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/pulp4/cde.git
git@gitee.com:pulp4/cde.git
pulp4
cde
cde
master

搜索帮助