6 Star 0 Fork 0

OpenCloudOS Stream/perl-Types-URI

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
perl-Types-URI.spec 3.67 KB
一键复制 编辑 原始数据 按行查看 历史
fanjunkong 提交于 2024-07-31 16:00 . update
%bcond_without perl_Types_URI_enables_optional_test
%define optional_test %[%{with perl_Types_URI_enables_optional_test} && !%{defined %perl_bootstrap}]
Name: perl-Types-URI
Version: 0.007
Release: 2%{?dist}
Summary: Type constraints and coercions for URIs
License: (GPL+ or Artistic) and Public Domain
URL: https://metacpan.org/release/Types-URI
Source0: https://cpan.metacpan.org/authors/id/T/TO/TOBYINK/Types-URI-%{version}.tar.gz
BuildArch: noarch
BuildRequires: make
BuildRequires: perl-generators
BuildRequires: perl-interpreter
BuildRequires: perl(Config)
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
BuildRequires: perl(strict)
BuildRequires: perl(:VERSION) >= 5.8
BuildRequires: perl(Type::Library) >= 1.000000
BuildRequires: perl(Types::Path::Tiny)
BuildRequires: perl(Types::Standard)
BuildRequires: perl(Types::UUID)
BuildRequires: perl(URI)
BuildRequires: perl(URI::data)
BuildRequires: perl(URI::file)
BuildRequires: perl(URI::FromHash)
BuildRequires: perl(URI::WithBase)
BuildRequires: perl(warnings)
BuildRequires: perl(if)
BuildRequires: perl(Test::More) >= 0.96
%if %{optional_test}
BuildRequires: perl(Attean)
BuildRequires: perl(Attean::IRI)
BuildRequires: perl(IRI) >= 0.004
BuildRequires: perl(Moose) >= 2.0000
BuildRequires: perl(RDF::Trine) >= 1.000
BuildRequires: perl(Test::Requires)
BuildRequires: perl(Types::Attean) >= 0.024
BuildRequires: perl(Types::Namespace) >= 1.10
%endif
Requires: perl(Type::Library) >= 1.000000
%global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\((Moose|Test::More|Type::Library|Types::Attean|Types::Namespace)\\)$
%description
Types::URI is a type constraint Perl library suitable for use with Moo/Moose
attributes, Kavorka sub signatures, and so forth.
%package tests
Summary: Tests for %{name}
Requires: %{name} = %{version}-%{release}
Requires: perl-Test-Harness
Requires: perl(Test::More) >= 0.96
%if %{optional_test}
Requires: perl(Attean)
Requires: perl(IRI) >= 0.004
Requires: perl(Moose) >= 2.0000
Requires: perl(RDF::Trine) >= 1.000
Requires: perl(Types::Attean) >= 0.024
Requires: perl(Types::Namespace) >= 1.10
%endif
%description tests
Tests from %{name}. Execute them
with "%{_libexecdir}/%{name}/test".
%prep
%setup -q -n Types-URI-%{version}
%if !%{optional_test}
for F in t/02attean.t t/02trine.t t/03iri.t t/50mxt-basic.t t/51mxt-fully-qualified.t; do
rm "$F"
perl -i -ne 'print $_ unless m{^\Q'"$F"'\E}' MANIFEST
done
%endif
for F in t/*.t; do
perl -i -MConfig -ple 'print $Config{startperl} if $. == 1 && !s{\A#!\s*perl}{$Config{startperl}}' "$F"
chmod +x "$F"
done
%build
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
%{make_build}
%install
%{make_install}
%{_fixperms} %{buildroot}/*
mkdir -p %{buildroot}%{_libexecdir}/%{name}
cp -a t %{buildroot}%{_libexecdir}/%{name}
cat > %{buildroot}%{_libexecdir}/%{name}/test << 'EOF'
%if %{optional_test}
unset AUTHOR_TESTING
%endif
cd %{_libexecdir}/%{name} && exec prove -I . -j "$(getconf _NPROCESSORS_ONLN)"
EOF
chmod +x %{buildroot}%{_libexecdir}/%{name}/test
%check
%if %{optional_test}
unset AUTHOR_TESTING
%endif
export HARNESS_OPTIONS=j$(perl -e 'if ($ARGV[0] =~ /.*-j([0-9][0-9]*).*/) {print $1} else {print 1}' -- '%{?_smp_mflags}')
make test
%files
%license LICENSE
%doc Changes COPYRIGHT CREDITS README
%{perl_vendorlib}/*
%{_mandir}/man3/*
%files tests
%{_libexecdir}/%{name}
%changelog
* Wed Jul 31 2024 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 0.007-2
- disable bootstrap
* Thu Jun 20 2024 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 0.007-1
- initial build
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/opencloudos-stream/perl-Types-URI.git
git@gitee.com:opencloudos-stream/perl-Types-URI.git
opencloudos-stream
perl-Types-URI
perl-Types-URI
master

搜索帮助

23e8dbc6 1850385 7e0993f3 1850385